Bug 129811 - kernel 2.6.7-1.494.2.2 / sendmail-8.12.11-4.6 smtp slow
kernel 2.6.7-1.494.2.2 / sendmail-8.12.11-4.6 smtp slow
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-08-12 16:31 EDT by Mike Reagan
Modified: 2015-01-04 17:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 00:34:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike Reagan 2004-08-12 16:31:38 EDT
Description of problem:
When sending emails with attachments the server would be occasionally
very slow.  The email client would be tied up trying to send.  

Version-Release number of selected component (if applicable):

Running Fedora Core 2 with 
	- kernel 2.6.7-1.494.2.2
	- sendmail-8.12.11-4.6

How reproducible:

Cyclical.  At points it wouldn't happen at all then you'd have a point
were nearly everytime you tried to send an email with an attachment it
would slow to a crawl.

Steps to Reproduce:
1.  Attempted to send email with attachment from a windows machine
using a linux machine with the above kernel/sendmail running.  
Actual results:
Occasionally email would take a very long time to be sent from the
email client to the linux server

Expected results:

Communication to be quicker

Additional info:

I switched back to kernel 2.6.6-1.435.2.3 and the problem seemed to
Comment 1 Mike Reagan 2004-08-13 13:11:37 EDT
Default values of these parameters in kernel 2.6.7:

    net.ipv4.tcp_default_win_scale = 7
    net.ipv4.tcp_moderate_rcvbuf = 1

These values in kernel 2.6.6 were both zero.
I ran the following and it seemed to fix my problem:

    sysctl -w net.ipv4.tcp_default_win_scale=0
    sysctl -w net.ipv4.tcp_moderate_rcvbuf=0
Comment 2 Dave Jones 2004-11-27 17:34:41 EST
mass update for old bugs:

Is this still a problem in the 2.6.9 based kernel update ?
Comment 3 Dave Jones 2005-04-16 00:34:03 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.