Bug 1298114 - full documentation of skyring REST API including basic examples
full documentation of skyring REST API including basic examples
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: core (Show other bugs)
2
Unspecified Unspecified
unspecified Severity high
: ---
: 3
Assigned To: Nishanth Thomas
sds-qe-bugs
: Reopened
Depends On: 1339605
Blocks: 1312404
  Show dependency treegraph
 
Reported: 2016-01-13 04:51 EST by Martin Kudlej
Modified: 2017-03-23 00:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:05:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-01-13 04:51:32 EST
Description of problem:
I think that REST API should be built according some rules. I've found good example of rules which can be reused and extended/modified for RHSCon:
https://github.com/ManageIQ/manageiq_docs/blob/master/api/overview/http.adoc

Similar specification for authentication:
https://github.com/ManageIQ/manageiq_docs/blob/master/api/overview/auth.adoc

I think that rules for RHSCon should be also documented in documentation.
Comment 3 Martin Kudlej 2016-04-22 06:35:13 EDT
I still think that for example return codes should be unified among all functions in API. But we can only document rules according API is built. --> documentation
Comment 4 Martin Bukatovic 2016-05-25 08:26:53 EDT
Moving to core component, because the API documentation needs to be part of
upstream repository directly written by developers. Anjana is not going to
fully document the API including few basic examples based on the source code.
Comment 5 Martin Bukatovic 2016-05-25 08:29:17 EDT
Upstream issue: https://github.com/skyrings/skyring/issues/13

Note You need to log in before you can comment on or make changes to this bug.