Bug 129812 - SELinux FAQ devel - writing in progress
SELinux FAQ devel - writing in progress
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: selinux-faq (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
http://people.redhat.com/kwade/fedora...
: FutureFeature
Depends On:
Blocks: fedora-docs-ready
  Show dependency treegraph
 
Reported: 2004-08-12 16:58 EDT by Karsten Wade
Modified: 2007-04-18 13:10 EDT (History)
0 users

See Also:
Fixed In Version: current
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-12 15:08:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2004-08-12 16:58:51 EDT
This bug is for tracking the lifecycle of the SELinux FAQ.  During
development, this bug will be used to move from the in progress
tracker (129807) to the ready for publication tracker (129722).

Current versions are always in CVS, and most likely at:

http://people.redhat.com/kwade/fedora-docs/selinux-faq-en/
http://people.redhat.com/kwade/fedora-docs/selinux-faq/selinux-faq-en.xml

The Fedora SELinux FAQ tracker bug (for bugfixes) is at:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118757
Comment 1 Karsten Wade 2004-09-23 16:15:00 EDT
The FC3test2 version of the SELinux FAQ has been uploaded to:

http://fedora.redhat.com/docs/selinux-faq-fc3test2/

Navigation and page references need to be updated.  For this, the bug
has been reassigned to tfox@redhat.com and moved to block bug #129722.

For the left side nav (include/navigation.inc), I had this thought:

1. Make SELinux FAQ a link to docs/selinux-faq/.

2. Cascading down in the Navigation tool would be links to specific
versions of the FAQ:
SELinux FAQ
  FC2 SELinux FAQ
  FC3test2 SELinux FAQ

The test version would be updated for each test release, then changed
to the final release.

3. The page at projects/selinux-faq/ would briefly explain the
existence and usage of the multiple FAQs, with links to them.

How are these regular pages created?  Is it from raw HTML or can I do
the page in XML?  I can create everything in my local tree and submit
my patches to you for approval and/or inclusion.

Whenever the changes are made, please move this bug back to blocking
bug #129807.
Comment 2 Tammy Fox 2004-09-24 11:38:18 EDT
Since the URL you created is specific to a test version, next time it
might be better to use docs/selinux-faq-fc3/ since the document
already has a warning that it is specific to a test release. That way,
we don't have to change the URL for every test release and the final
release or worry about removing tags. Since all the files tagged LIVE
show up on the website, before you remove this directory from CVS, be
sure to untag the files so they are removed from the live site as well.

I added a link to the SELinux FC3test2 FAQ on docs/.

Having a landing page at docs/selinux-faq/ sounds like a great idea.
Instead of typing the instructions in Bugzilla, I'll contact you about
how to do this and the navigation changes.
Comment 3 Karsten Wade 2004-09-25 20:22:08 EDT
What you describe in the first paragraph makes sense.

Is there any value in doing a fix?  Call it a brown paper bag release ...

We could make a docs/selinux-faq-fc3/, and make selinux-faq-fc3test2/
a symlink (or the equivalent in CVS) ... or just maintain them both
... for a little while.  I can replace all the references within the
docs, reissue the corrected URL, and can maintain the one-off by
ignoring it, one day perhaps removing it altogether.

Comment 4 Tammy Fox 2004-09-27 10:55:04 EDT
My suggestion would be to correct the URL now and have a redirect
until the end of the FC3 test cycle. After that, I don't think anyone
is going to be looking for the FAQs specific to test 2.
Comment 5 Tammy Fox 2007-01-12 15:08:39 EST
This bug pertains to FC3 test2. I'm closing it out since I don't think it is
relavant anymore.

Note You need to log in before you can comment on or make changes to this bug.