Bug 1298150 - qemu's watchdog does not work?
qemu's watchdog does not work?
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.1
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 05:53 EST by lejeczek
Modified: 2016-01-14 11:31 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 10:31:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2016-01-13 05:53:32 EST
Description of problem:

I have this in my guest:

    <watchdog model='i6300esb' action='reset'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
    </watchdog>

and even though watchdog.service(with plain-vanilla config) is stopped the guess is fine, up & running.
Is this expected?

Version-Release number of selected component (if applicable):

qemu-kvm-common-ev-2.3.0-29.1.el7.x86_64
qemu-kvm-ev-2.3.0-29.1.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Cole Robinson 2016-01-14 10:31:08 EST
Since you are using centos, and this is really more of a config question than a bug, please take this to an upstream mailing list like libvirt-users@redhat.com

But you say that watchdog.service is _stopped_ inside the VM... it needs to be running. There's some more info here: https://rwmj.wordpress.com/2010/03/03/what-is-a-watchdog/
Comment 3 lejeczek 2016-01-14 11:31:33 EST
sorry, my understanding was that hardware (here qemu's watchdog) would take action(reboot) the system if there is no ping from the OS watchdog, so I thought stopping watchdog service in VM should be a quick test.
I'll check mailing list. Many thanks

Note You need to log in before you can comment on or make changes to this bug.