Bug 1298159 - NTP sync host cannot be validated on re-run of the fusor-installer
NTP sync host cannot be validated on re-run of the fusor-installer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: TP3
: 1.0
Assigned To: Fabian von Feilitzsch
Dave Johnson
: Triaged
Depends On:
Blocks: rhci-sprint-14
  Show dependency treegraph
 
Reported: 2016-01-13 06:36 EST by Antonin Pagac
Modified: 2016-04-29 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 12:25:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2016-01-13 06:36:49 EST
Description of problem:
While verifying another bug, I submitted bad NTP server to the fusor-installer, then choose to not continue with installation. Then I submitted a valid NTP host, fusor-installer verified it and installation continued, but there was an error and it did not finish successfully. So I'm trying to re-run again, but now the installer always reports:

"WARNING!! - NTP sync host "<HOST>" does not appear to be valid!"

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20160107.t.1-RHCI-x86_64-dvd1.iso
RHCIOOO-7-RHEL-7-20160112.t.1-RHCIOOO-x86_64-dvd1.iso

How reproducible:
Hit this first time

Steps to Reproduce:
1. Run fusor-installer with valid NTP server
2. You may need to kill the installation or otherwise cause an error
3. Re-run fusor-installer with the same server

Actual results:
Valid NTP sync host cannot be validated on re-run of fusor-installer

Expected results:
Valid NTP host should always be green

Additional info:
Comment 2 Antonin Pagac 2016-01-13 06:41:42 EST
While I was reporting this, it seems to have fixed itself and now, on another re-run, it correctly reports "NTP sync host is ok"
Comment 3 Antonin Pagac 2016-01-13 07:49:50 EST
I have reproduced this behavior, if I leave it be for ~30 min and then re-run the installer, the NTP host is reported to be OK.
Comment 4 Fabian von Feilitzsch 2016-03-08 14:05:10 EST
I am not able to replicate this, are you still seeing it?
Comment 5 Antonin Pagac 2016-03-09 08:11:29 EST
Fabian,

I'm unable to reproduce this issue using TP2 RC9 ISO, it seems fixed now.

Note You need to log in before you can comment on or make changes to this bug.