Bug 1298160 - [RFE] Cockpit plugin to start hosted-engine-setup for the first host
[RFE] Cockpit plugin to start hosted-engine-setup for the first host
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: RFEs (Show other bugs)
3.6
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-beta
: 4.0
Assigned To: Ryan Barry
cshao
: FutureFeature
Depends On:
Blocks: ovirt-node-ng 1350697
  Show dependency treegraph
 
Reported: 2016-01-13 06:36 EST by Fabian Deutsch
Modified: 2016-07-05 03:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: cockpit-ovirt-0.5.1.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:51:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
ycui: testing_plan_complete?
ylavi: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55779 None None None 2016-04-07 16:20 EDT

  None (edit)
Description Fabian Deutsch 2016-01-13 06:36:50 EST
Description of problem:
There should be a cockpit plugin to start the hosted.engine-setup on the first host.
The UI of the plugin should do everything inside cockpit, there should not be any need to drop to shell or alike.

Additional hosts can be deployed from Engine.
Comment 1 Yaniv Kaul 2016-01-14 03:04:15 EST
(In reply to Fabian Deutsch from comment #0)
> Description of problem:
> There should be a cockpit plugin to start the hosted.engine-setup on the
> first host.
> The UI of the plugin should do everything inside cockpit, there should not
> be any need to drop to shell or alike.
> 
> Additional hosts can be deployed from Engine.

As well as provide status on the HE VM, etc.
With a bit of luck, perhaps it can do the deploy on other hosts as well...
Comment 2 Ryan Barry 2016-04-07 16:19:57 EDT
This basically works. Patch is pending upstream (with some small amounts of cosmetic work still going into it), but:

hosted-engine setup works

The elements are hidden until a "Start Setup" button is pressed.

INFO, WARNING, and ERROR messages are propagated to patternfly messages. Unclassified output is sent to a textbox.

The input field is pre-populated if a suggested input is part of the output (Yes/No) [Yes]:, for example.

The input field is flagged as invalid if hosted-engine setup returns an error from some value.

There's a copr at https://copr.fedorainfracloud.org/coprs/rbarry/cockpit-ovirt/ hosting the results (updated when a patch is submitted) until it merges upstream.
Comment 3 Sandro Bonazzola 2016-05-02 05:59:15 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 4 wanghui 2016-06-02 00:48:33 EDT
Start the hosted.engine-setup on the first host is basically worked in rhev-hypervisor7-ng-4.0-20160527.0(cockpit-ovirt-dashboard-0.10.1-0.0.1.el7ev.noarch) now. But it still has some detail issue need to be fixed. Due to this is a RFE bug, we prefer to verify this issue and let detail bugs to track the specific issues.
Comment 6 Sandro Bonazzola 2016-07-05 03:51:58 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.