Bug 1298167 - RFE python-qpid - Add support for python3 [NEEDINFO]
Summary: RFE python-qpid - Add support for python3
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: python-qpid
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Irina Boverman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3-UPSTREAM 1194577
TreeView+ depends on / blocked
 
Reported: 2016-01-13 11:59 UTC by Raphael Groner
Modified: 2019-08-14 10:33 UTC (History)
8 users (show)

Fixed In Version: python-qpid-1.37.0-1.el7 python-qpid-1.37.0-1.fc26 python-qpid-1.37.0-1.fc27
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-13 22:34:16 UTC
mhroncok: needinfo? (iboverma)


Attachments (Terms of Use)
add support for python3 (17.88 KB, patch)
2016-01-13 12:00 UTC, Raphael Groner
no flags Details | Diff
add support for python3 (17.94 KB, patch)
2016-01-13 12:20 UTC, Raphael Groner
projects.rg: review? (iboverma)
Details | Diff

Description Raphael Groner 2016-01-13 11:59:03 UTC
Description of problem:
Please add support for python3. Though, upstream of Apache Qpid is dead.

Version-Release number of selected component (if applicable):
-

How reproducible:
-

Steps to Reproduce:
1. dnf install python3-qpid
2.
3.

Actual results:
fail

Expected results:
python3-qpid package can be installed

Additional info:
see attachment

Comment 1 Raphael Groner 2016-01-13 12:00:58 UTC
Created attachment 1114378 [details]
add support for python3

Features also to run tests, some of them need a running rabbitmq-server.

Comment 2 Raphael Groner 2016-01-13 12:20:25 UTC
Created attachment 1114395 [details]
add support for python3

Features also to run tests, some need a running instance of rabbitmq-server.

Comment 3 Raphael Groner 2016-01-13 12:21:24 UTC
I'll try to send a better patch (without direct calls of 2to3 or modernize) to upstream.

Comment 4 Justin Ross 2016-01-19 15:53:12 UTC
(In reply to Raphael Groner from comment #3)
> I'll try to send a better patch (without direct calls of 2to3 or modernize)
> to upstream.

Hi, Raphael.  I'm watching this issue so I pick up your improved patch.  Once you attach it, I'll get it reviewed.

Comment 5 Raphael Groner 2016-02-03 23:01:40 UTC
Setting priority to not forget about this bug.

Comment 6 Raphael Groner 2016-02-06 18:27:11 UTC
Are you aware about the GitHub mirror¹ of Qpid and especially python module? I see a lot of patches there, done after the 0.32 release. Maybe it's reasonable to update the package to some post-release?

While my tries to create a proper python3 patch, I detect a lot of hacks for older python (version 2.3) in the sources that do not work after 2to3 tool's applied.

¹ https://github.com/apache/qpid/tree/trunk/qpid/python

Comment 7 Collin Anderson 2016-02-25 19:56:57 UTC
If it helps, I believe the official upstream repos are here and appear active:

https://git1-us-west.apache.org/repos/asf?a=project_list&s=qpid

Proton specifically claims to have PY3 support merged as of Jun 22, 2015.

http://qpid.2158936.n2.nabble.com/Python-3-port-is-done-td7623782.html

Comment 8 Raphael Groner 2017-09-22 11:13:17 UTC
Ping? Any news here?

Comment 9 Fedora Update System 2017-12-01 18:58:49 UTC
python-qpid-1.37.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0233f4ea2e

Comment 10 Fedora Update System 2017-12-01 18:59:03 UTC
python-qpid-1.37.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-432cb6bb51

Comment 11 Fedora Update System 2017-12-01 18:59:12 UTC
python-qpid-1.37.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-81c89b85c0

Comment 12 Irina Boverman 2017-12-02 01:35:14 UTC
This component does not support python 3.

Comment 13 Raphael Groner 2017-12-02 11:31:46 UTC
(In reply to Irina Boverman from comment #12)
> This component does not support python 3.

I still fail to understand why you reference this bug with the explicit request for python3 support.

Comment 14 Fedora Update System 2017-12-02 19:56:32 UTC
python-qpid-1.37.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0233f4ea2e

Comment 15 Fedora Update System 2017-12-02 21:48:06 UTC
python-qpid-1.37.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-81c89b85c0

Comment 16 Fedora Update System 2017-12-02 22:40:24 UTC
python-qpid-1.37.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-432cb6bb51

Comment 18 Fedora Update System 2018-01-13 22:34:16 UTC
python-qpid-1.37.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-01-13 23:04:20 UTC
python-qpid-1.37.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-01-13 23:18:28 UTC
python-qpid-1.37.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Raphael Groner 2018-01-14 18:54:34 UTC
Not fixed. Again, please do not reference bugs without validation.

Comment 22 Miro Hrončok 2019-07-24 15:00:50 UTC
What is the status here? Should the packages be dropped instead?

Comment 23 Raphael Groner 2019-07-25 01:22:38 UTC
Well, at least there seems to be some preparation work for switching to another python.
https://src.fedoraproject.org/rpms/python-qpid/c/faeb6e5cc54874f607f158f273c2e95b645ace36

(In reply to Irina Boverman from comment #12)
> This component does not support python 3.

Does this statement still count?

Comment 24 Dan Callaghan 2019-08-14 10:30:08 UTC
I was about to retire the Python support in saslwrapper (bug 1738175) when I noticed that python-qpid still depends on it.

But it seems like upstream maintenance of these packages has totally stopped. There is the "new" Qpid Proton implementation and upstream seems to prefer that over the original qpid-python.

Maybe it is time to just retire this group of packages (python-qpid, qpid-cpp, saslwrapper)?

Comment 25 Dan Callaghan 2019-08-14 10:33:18 UTC
For example, in 2016 this issue with closed as wontfix: https://issues.apache.org/jira/browse/QPID-3668

"Forward development for Python is now focused on the Proton Python binding. As a result, we are considering only defects and minor improvements for the Python qpid.messaging API. These issues are closed "won't fix" because they are improvements outside of that scope."

and in 2017 when asked about Python 3 support: https://mail-archives.apache.org/mod_mbox/qpid-users/201712.mbox/%3CCAFcPDB9vOr_7sYqJA-3b0YF5%3DkP9aSi8aNNDrDA_NOSnYoyZ4A%40mail.gmail.com%3E

"I'm not aware of any plans to work on Python 3 support for qpid-python,
although it's possible somebody else has an interest in it. If you are
interested in working on it yourself, open a JIRA and attach patches, we
can get them applied to a future release."

(which itself seems to be at odds with the earlier statement about closing JIRA issues.)


Note You need to log in before you can comment on or make changes to this bug.