This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1298193 - Retire vm doesn't work on Azure cloud provider
Retire vm doesn't work on Azure cloud provider
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: William Fitzgerald
Jeff Teehan
azure:vm:retirement
:
Depends On:
Blocks: 1291274
  Show dependency treegraph
 
Reported: 2016-01-13 07:44 EST by Taras Lehinevych
Modified: 2016-08-02 21:33 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:29:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Azure retire vm (134.58 KB, image/png)
2016-01-13 07:44 EST, Taras Lehinevych
no flags Details
evm.log (4.49 MB, text/plain)
2016-01-13 07:50 EST, Taras Lehinevych
no flags Details
automation.log (141.74 KB, text/plain)
2016-01-13 07:50 EST, Taras Lehinevych
no flags Details

  None (edit)
Description Taras Lehinevych 2016-01-13 07:44:10 EST
Created attachment 1114397 [details]
Azure retire vm

Description of problem:
When you retire vm on azure provider the power state of vm should be off/stopped what means that vm isn't running, however only the status of vm is change to retired. Please take a look at screenshot.
Also, I'll attach emv and automation log files.

Version-Release number of selected component (if applicable):
5.5.2.0

How reproducible:
Always

Steps to Reproduce:
1. Set up Azure cloud provider
2. Open any virtual machine
3. Press Lifecycle -> Retire this VM
5. Wait a little bit and check the status of vm and power state

Actual results:
The status of vm is Retired but power state is on

Expected results:
The power state of vm should be off, also cfme shouldn't allow vm to start/power on

Additional info:
The vm navigation tree update status of vm after reload, so please press on "All VMs & Templates" to update statuses.

Appliance info:
IP is 10.8.59.182 
The vm name is testvmretire
This vm was create only for this test, so you can do whatever you need with this vm.
Comment 2 Taras Lehinevych 2016-01-13 07:50 EST
Created attachment 1114398 [details]
evm.log
Comment 3 Taras Lehinevych 2016-01-13 07:50 EST
Created attachment 1114399 [details]
automation.log
Comment 4 Bill Wei 2016-01-20 18:07:55 EST
Billy, 
The failure is likely caused by the missing method reported in https://bugzilla.redhat.com/show_bug.cgi?id=1291274. Can you take a look and ported the PR to downstream. Please check with Tina.
Comment 5 William Fitzgerald 2016-01-21 14:49:36 EST
I can't access your appliance. Can you make this available for me?
Comment 6 Jeff Teehan 2016-01-21 17:44:42 EST
Use this one for 5.5.2.1  It's configured already.
https://10.16.6.21
Comment 7 William Fitzgerald 2016-01-21 17:56:16 EST
The generic pre_retirement method is missing.

/ManageIQ/Cloud/VM/Retirement/StateMachines/Methods/pre_retirement

We are working on a fix now.
Comment 8 Tina Fitzgerald 2016-02-11 14:16:06 EST
This issue has been resolved: https://github.com/ManageIQ/manageiq/pull/5779
Comment 9 Jeff Teehan 2016-04-18 13:52:23 EDT
This is verified as working.  I've terminated or otherwise retired 10 different instances without any issues.

Tested on 5.6.0.1 Beta on on https://10.16.7.174/vm_cloud/explorer
Comment 11 errata-xmlrpc 2016-06-29 11:29:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.