Bug 1298202 - various issues and JVM dead when registering lots of profiles in parallel
various issues and JVM dead when registering lots of profiles in parallel
Status: CLOSED DUPLICATE of bug 1298061
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
570
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 08:26 EST by Jan Hutař
Modified: 2016-01-29 13:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 13:47:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2016-01-13 08:26:47 EST
Description of problem:
There are various issues in logs and killed JVM when registering lots of profiles in parallel.

Satellite's HW was:
  Intel Platform: DigitalOffice CPU: SandyBridge D2
  Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz
  3717 MB memory, 500 GB disk space


Version-Release number of selected component (if applicable):
Satellite 5.7.0 @ embedded PostgreSQL
satellite-schema-5.7.0.20-1.el6sat.noarch
spacewalk-java-2.3.8-120.el6sat.noarch
spacewalk-backend-2.3.3-33.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Register 500 systems in parallel


Actual results:
JVM dies (i.e. are down) and there is one APPARENT DEADLOCK in catalina.out.

Only 292 systems out of 500 gets registered, 105 of these were missing package profile.


Expected results:
Satellite survives. If the system gets registered, its package profile is loaded.
Comment 2 Jan Hutař 2016-01-14 01:30:06 EST
When you have taskomatic and rhn-search stopped while registering, all 500 systems get registered.

After I have started rhn-search, it took to it about 10 minutes to process new stuff on the Satellite.

After I have started ErrataCacheTask, it took to it only about 1 minute to process 500 new items in ErrataCacheTask queue.
Comment 3 Jan Hutař 2016-01-14 01:31:27 EST
(note that each system had 45/47 applicable erratas/packages)
Comment 4 Grant Gainey 2016-01-29 13:47:45 EST
In spite of having different databases, the problem here is the same as in 1298061 - more incoming connections than the allowed-max-db-connections. I'm closing this as a dup of that BZ.

*** This bug has been marked as a duplicate of bug 1298061 ***

Note You need to log in before you can comment on or make changes to this bug.