Bug 1298203 - improve get,put,evict,expire logging
improve get,put,evict,expire logging
Status: CLOSED DEFERRED
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.5.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 08:30 EST by Shay Matasaro
Modified: 2016-03-29 03:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 08:56:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker PRODMGT-1436 Major Resolved Access log and statistics of cache operations 2017-07-28 05:50 EDT

  None (edit)
Description Shay Matasaro 2016-01-13 08:30:07 EST
For the purpose of diagnostics and troubleshooting more detailed logging is required, specifically:

PUT  
------
for dist mode which node became the owner
time to complete op

GET
-----
in dist mode was the key found locally ? 
which node owned the key?
time to complete op

eviction
-------
which entries were evicted ?
last usage timestamp


expiration
---------
was the key evicted to due to life span or idle time
idle time and life span for expired key
Comment 2 Shay Matasaro 2016-01-13 08:35:31 EST
as far as i can see expired entries are not logged at all
Comment 4 wfink 2016-01-20 08:56:05 EST
This enhancement is already considered for JDG7.x.

If you are interested in more information or want to vote on it, feel free to open a support case with a reference to this issue.
We might able to give more information then.

Note You need to log in before you can comment on or make changes to this bug.