Bug 1298204 - tuned: race condition when generating modprobe file
tuned: race condition when generating modprobe file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.3
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
: Patch, ZStream
Depends On: 1292117
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 08:32 EST by Jan Kurik
Modified: 2016-02-16 06:18 EST (History)
9 users (show)

See Also:
Fixed In Version: tuned-2.5.1-4.el7.2
Doc Type: Bug Fix
Doc Text:
Cause: Previously there existed race condition in realtime-virtual-host Tuned profile. Consequence: The modprobe configuration file for KVM RT could be generated after the KVM modules are loaded causing the modules options to be not used. This can result in latency spike. The modprobe configuration file was (re)generated on each Tuned start (machine boot) and profile activation which increased the probability that the race condition will be triggered. Fix: Tuned code was extended to provide hint to profiles why it executes "stop" callback and the realtime-virtual-host profile was updated to use this hint and conditionally generate the modprobe configuration file only when the profile is activated (selected). Result: Now the modprobe configuration file is generated only when the realtime-virtual-host profile is activated (selected). The profile activation needs to be followed by machine reboot. During the reboot the modprobe configuration file is not (re)generated again which removes the race condition.
Story Points: ---
Clone Of: 1292117
Environment:
Last Closed: 2016-02-16 06:18:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-01-13 08:32:07 EST
This bug has been copied from bug #1292117 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Tereza Cerna 2016-01-27 02:54:20 EST
Verified in tuned-2.5.1-4.el7_2.2 - PASS

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Command 'systemctl restart tuned' (Expected 0, got 0)
:: [   PASS   ] :: Command 'journalctl -b | grep -q "profile_switch"' (Expected 1, got 1)
:: [   PASS   ] :: Command 'tuned-adm profile test' (Expected 0, got 0)
:: [   PASS   ] :: Command 'journalctl -b | grep -q "profile_switch"' (Expected 0, got 0)
:: [   PASS   ] :: RESULT: Test

_______________________________________________________________

Reproduced in tuned-2.5.1-4.el7 - FAIL

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Command 'systemctl restart tuned' (Expected 0, got 0)
:: [   PASS   ] :: Command 'journalctl -b | grep -q "profile_switch"' (Expected 1, got 1)
:: [   PASS   ] :: Command 'tuned-adm profile test' (Expected 0, got 0)
:: [   FAIL   ] :: Command 'journalctl -b | grep -q "profile_switch"' (Expected 0, got 1)
:: [   FAIL   ] :: RESULT: Test
Comment 6 errata-xmlrpc 2016-02-16 06:18:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0213.html

Note You need to log in before you can comment on or make changes to this bug.