Bug 1298205 - Unable to install JDV on MS Azure
Unable to install JDV on MS Azure
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Hauser
Juraj Duráni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 08:35 EST by Juraj Duráni
Modified: 2016-01-25 08:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 02:45:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Installation log (84.43 KB, text/plain)
2016-01-13 08:35 EST, Juraj Duráni
no flags Details

  None (edit)
Description Juraj Duráni 2016-01-13 08:35:57 EST
Created attachment 1114404 [details]
Installation log

Description of problem:
Installation fails during installation of JDV in standalone-full-ha mode.


JBOSS_HOME adjusted to: /home/jdurani/EAP-6.4.0
=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /home/jdurani/EAP-6.4.0

  JAVA: java

  JAVA_OPTS:  -server -XX:+UseCompressedOops -verbose:gc -Xloggc:"/home/jdurani/EAP-6.4.0/standalone/log/gc.log" -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=5 -XX:GCLogFileSize=3M -XX:-TraceClassUnloading -Xms1303m -Xmx1303m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.modules.policy-permissions=true

=========================================================================

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
09:44:27,755 INFO  [org.jboss.modules] (main) JBoss Modules version 1.3.7.Final-redhat-1
09:44:28,181 INFO  [org.jboss.msc] (main) JBoss MSC version 1.1.5.Final-redhat-1
09:44:28,368 INFO  [org.jboss.as] (MSC service thread 1-2) JBAS015899: JBoss Red Hat JBoss Data Virtualization 6.2.0 (AS 7.5.4.Final-redhat-4) starting
09:44:31,644 INFO  [org.xnio] (MSC service thread 1-1) XNIO Version 3.0.14.GA-redhat-1
[ Server code detected: JBAS015888 ]
Waiting for server to be ready. This could take up to 40 seconds.
jan 11, 2016 9:44:31 AM com.redhat.installer.asconfiguration.ascontroller.ServerCommands setLogger
INFO: Running commands from: com.redhat.installer.asconfiguration.processpanel.CliScriptHelper
Trying to connect to Management Interface...(1/5).
Trying to connect to Management Interface...(2/5).
Trying to connect to Management Interface...(3/5).
Trying to connect to Management Interface...(4/5).
Trying to connect to Management Interface...(5/5).
Failed to connect to Management Interface after 5 attempts.
jan 11, 2016 9:44:31 AM com.redhat.installer.asconfiguration.ascontroller.ServerCommands handle
INFO: /subsystem=web/virtual-server=default-host:write-attribute(name=enable-welcome-root,value=false)
jan 11, 2016 9:44:31 AM com.redhat.installer.asconfiguration.ascontroller.ServerCommands closeLogHandlers
INFO: Finished commands from: com.redhat.installer.asconfiguration.processpanel.CliScriptHelper
Script /home/jdurani/EAP-6.4.0/cli-scripts/disable-welcome-root.cli failed to run.
JBoss CLI command failed: /subsystem=web/virtual-server=default-host:write-attribute(name=enable-welcome-root,value=false)
{
    "outcome" => "failed",
    "failure-description" => "No ModelControllerClient was available to execute the request.",
    "command" => "/subsystem=web/virtual-server=default-host:write-attribute(name=enable-welcome-root,value=false)"
}
Running on-fail server check.
Shutting server down.
jan 11, 2016 9:44:31 AM com.redhat.installer.asconfiguration.ascontroller.ServerCommands setLogger
INFO: Running commands from: com.redhat.installer.asconfiguration.ascontroller.ServerManager
Trying to connect to Management Interface...(1/5).
Trying to connect to Management Interface...(2/5).
Trying to connect to Management Interface...(3/5).
Trying to connect to Management Interface...(4/5).
Trying to connect to Management Interface...(5/5).
Failed to connect to Management Interface after 5 attempts.
jan 11, 2016 9:44:31 AM com.redhat.installer.asconfiguration.ascontroller.ServerCommands handle
INFO: :shutdown
jan 11, 2016 9:44:31 AM com.redhat.installer.asconfiguration.ascontroller.ServerCommands closeLogHandlers
INFO: Finished commands from: com.redhat.installer.asconfiguration.ascontroller.ServerManager
{"outcome" => "failed","failure-description" => "No ModelControllerClient was available to execute the request.","command" => ":shutdown"}
Successfully moved source: /home/jdurani/EAP-6.4.0/standalone/log/server.log to destination: /home/jdurani/EAP-6.4.0/installation/server-logs
The configured source file: /home/jdurani/EAP-6.4.0/domain/log/host-controller.log doesn't exist.
The configured source file: /home/jdurani/EAP-6.4.0/domain/log/process-controller.log doesn't exist.
Comment 1 Van Halbert 2016-01-13 08:39:00 EST
Does the user you used, have admin rights?
Comment 2 Juraj Duráni 2016-01-13 09:04:41 EST
I tried to install JDV into user's home directory. Admin rights are not needed.
Comment 3 Van Halbert 2016-01-13 09:19:11 EST
As indicated in the doc's: [1]

"Ensure that you have administration privileges for the installation directory."



[1] https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Data_Virtualization/6.2/html-single/Installation_Guide/index.html
Comment 4 Juraj Duráni 2016-01-13 09:27:22 EST
As I said. I tried to install it to user's home directory (directory /home/jdurani/EAP-6.4.0  user jdurani). It means I am the owner of the directory = I have admin rights.

Anyway, I was able to install EAP in same directory.
Comment 5 Juraj Duráni 2016-01-15 02:45:03 EST
I tried to install JDV on EAP 6.4.4 which is not supported (however, there was no problem when I was installing it on my local machine with same configuration). Installation completed correctly with EAP 6.4.3.

Closing this with resolution "not a bug". If you think that this is something you want to fix, feel free to reopen this BZ.

Note You need to log in before you can comment on or make changes to this bug.