Bug 1298207 - Error is not checked if mysql_store_result returns NULL
Error is not checked if mysql_store_result returns NULL
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: MySQL-python (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Honza Horak
qe-baseos-daemons
:
Depends On:
Blocks: 1400961
  Show dependency treegraph
 
Reported: 2016-01-13 08:42 EST by Attila Fazekas
Modified: 2017-02-01 08:08 EST (History)
3 users (show)

See Also:
Fixed In Version: MySQL-python-1.2.5-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-08 07:53:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1266849 None None None 2016-01-27 18:14 EST

  None (edit)
Description Attila Fazekas 2016-01-13 08:42:27 EST
Description of problem:
See The upstream bug report:
http://sourceforge.net/p/mysql-python/bugs/324/

Version-Release number of selected component (if applicable):
MySQL-python-1.2.3-11.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Set the mysql root password to 'root'
2. execute the http://sourceforge.net/p/mysql-python/bugs/_discuss/thread/67522657/7461/attachment/mysqldb-example.py

$ python mysqldb-example.py foo


Actual results:
no operational error raised !
Traceback (most recent call last):
  File "test.py", line 58, in <module>
    bad()
  File "test.py", line 48, in bad
    run_test("SELECT * FROM a WHERE a.id in (1, 2) FOR UPDATE")
  File "test.py", line 42, in run_test
    "cursor returned from SELECT with no description!"
AssertionError: cursor returned from SELECT with no description!

Expected results:
Traceback (most recent call last):
  File "test.py", line 58, in <module>
    bad()
  File "test.py", line 48, in bad
    run_test("SELECT * FROM a WHERE a.id in (1, 2) FOR UPDATE")
  File "test.py", line 39, in run_test
    curs1.execute(stmt)
  File "/root/.local/lib/python2.7/site-packages/MySQLdb/cursors.py", line 205, in execute
    self.errorhandler(self, exc, value)
  File "/root/.local/lib/python2.7/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
_mysql_exceptions.OperationalError: (1205, 'Lock wait timeout exceeded; try restarting transaction')

Additional info:
This issue affects Openstack,
Workaround: pip install -U MySQL-python==1.2.5 

The upstream bug references to this patch:
http://sourceforge.net/p/mysql-python/svn/655/tree//branches/MySQLdb-1.2/MySQLdb/_mysql.c?diff=5059d1f5bfc09e26e1a66617:654
Comment 5 Honza Horak 2016-12-08 07:52:43 EST
I believe this bug is already fixed, since MySQL-python-1.2.5-1.el7 is available. Can you confirm, Attila, please?
Comment 6 Attila Fazekas 2017-02-01 08:08:46 EST
The test works as expected, I got the 'Lock wait timeout exceeded; try restarting transaction' .

Note You need to log in before you can comment on or make changes to this bug.