Bug 1298214 - kdump service fails: Cannot open `/boot/vmlinuz-4.3.3-300.fc23.x86_64': Permission denied
kdump service fails: Cannot open `/boot/vmlinuz-4.3.3-300.fc23.x86_64': Permi...
Status: CLOSED DUPLICATE of bug 1244057
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Baoquan He
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 09:08 EST by Milan Bouchet-Valat
Modified: 2016-01-18 00:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 00:52:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bouchet-Valat 2016-01-13 09:08:37 EST
The kdump service fails to start on up-to-date Fedora 23 (upgraded from F22). The logs contain this (most recent messages above):

janv. 13 14:58:01 milan audit[2482]: AVC avc:  denied  { read } for  pid=2482 comm="kexec" name="vmlinuz-4.3.3-300.fc23.x86_64" dev="sda7" ino=138424 scontext=system_u:system_r:kdump_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=file permissive=0
janv. 13 14:58:01 milan kernel: audit: type=1400 audit(1452693481.071:468): avc:  denied  { read } for  pid=2482 comm="kexec" name="vmlinuz-4.3.3-300.fc23.x86_64" dev="sda7" ino=138424 scontext=system_u:system_r:kdump_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=file permissive=0
janv. 13 14:58:01 milan kernel: audit: type=1300 audit(1452693481.071:468): arch=c000003e syscall=2 success=no exit=-13 a0=7fff959bdf64 a1=0 a2=1b6 a3=23 items=0 ppid=1389 pid=2482 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kexec" exe="/usr/sbin/kexec" subj=system_u:system_r:kdump_t:s0 key=(null)
janv. 13 14:58:01 milan systemd[1]: kdump.service: Main process exited, code=exited, status=1/FAILURE
janv. 13 14:58:01 milan audit[2482]: SYSCALL arch=c000003e syscall=2 success=no exit=-13 a0=7fff959bdf64 a1=0 a2=1b6 a3=23 items=0 ppid=1389 pid=2482 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kexec" exe="/usr/sbin/kexec" subj=system_u:system_r:kdump_t:s0 key=(null)
janv. 13 14:58:01 milan systemd[1]: Failed to start Crash recovery kernel arming.
janv. 13 14:58:01 milan audit: PROCTITLE proctitle=2F7362696E2F6B65786563002D70002D2D636F6D6D616E642D6C696E653D424F4F545F494D4147453D2F626F6F742F766D6C696E757A2D342E332E332D3330302E666332332E7838365F363420726F6F743D555549443D32393439623337392D626437362D346564362D613262652D31326131626334363334633520726F2061
janv. 13 14:58:01 milan systemd[1]: kdump.service: Unit entered failed state.
janv. 13 14:58:01 milan systemd[1]: kdump.service: Failed with result 'exit-code'.
janv. 13 14:58:01 milan audit[2482]: AVC avc:  denied  { read } for  pid=2482 comm="kexec" name="vmlinuz-4.3.3-300.fc23.x86_64" dev="sda7" ino=138424 scontext=system_u:system_r:kdump_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=file permissive=0
janv. 13 14:58:01 milan systemd[1]: Started Harvest vmcores for ABRT.
janv. 13 14:58:01 milan audit[2482]: SYSCALL arch=c000003e syscall=2 success=no exit=-13 a0=7fff959bdf64 a1=0 a2=7fff959bbe80 a3=697 items=0 ppid=1389 pid=2482 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kexec" exe="/usr/sbin/kexec" subj=system_u:system_r:kdump_t:s0 key=(null)
janv. 13 14:58:01 milan audit: PROCTITLE proctitle=2F7362696E2F6B65786563002D70002D2D636F6D6D616E642D6C696E653D424F4F545F494D4147453D2F626F6F742F766D6C696E757A2D342E332E332D3330302E666332332E7838365F363420726F6F743D555549443D32393439623337392D626437362D346564362D613262652D31326131626334363334633520726F2061
janv. 13 14:58:01 milan audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=kdump comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
janv. 13 14:58:01 milan kdumpctl[1381]: Cannot open `/boot/vmlinuz-4.3.3-300.fc23.x86_64': Permission denied
janv. 13 14:58:01 milan kdumpctl[1381]: kexec: failed to load kdump kernel
janv. 13 14:58:01 milan kdumpctl[1381]: Starting kdump: [FAILED]
Comment 1 Dave Young 2016-01-18 00:52:01 EST

*** This bug has been marked as a duplicate of bug 1244057 ***

Note You need to log in before you can comment on or make changes to this bug.