Bug 1298223 - removing automatic VM pool with running vms fails constantly [NEEDINFO]
removing automatic VM pool with running vms fails constantly
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1.3
x86_64 Linux
low Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Shahar Havivi
meital avital
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 09:21 EST by Barak Korren
Modified: 2017-04-03 06:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-03 06:43:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
shavivi: needinfo? (bkorren)
tjelinek: ovirt‑4.2?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Barak Korren 2016-01-13 09:21:13 EST
Description of problem:
When removing an automatic pool with running VMs, the command will fail for the 1st time and succeed for the 2nd.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.6.1.3-1.el7.centos

How reproducible:
Always

Steps to Reproduce:
1. Create a VM pool from a template with a disk, set the pool size to at least 2 and set it to per-start at least 2 vms
2. wait for the vms to start up
3. try to remove the pool
   -> the VMs will be shut down but the removal task will fail and the pool
      will remain
4. try to remove the pool again
   -> this time the VMs and pool will be erased


Actual results:
Pool removal task fails

Expected results:
Pool removal task should succeed the first time
Comment 1 Michal Skrivanek 2016-01-29 08:59:08 EST
logs?
Comment 2 Barak Korren 2016-02-08 07:07:25 EST
I don't have the test system any more, so cannot provide logs at this time. Please follow steps to reproduce.
Comment 3 Tomas Jelinek 2016-02-11 06:50:07 EST
does not seem as something dangerous, only an annoyance - targeting 4.0 for consideration.
Comment 4 Moran Goldboim 2016-03-24 04:34:23 EDT
deferred to next version due to capacity.
Comment 5 Yaniv Kaul 2016-11-29 16:09:12 EST
(In reply to Tomas Jelinek from comment #3)
> does not seem as something dangerous, only an annoyance - targeting 4.0 for
> consideration.

And now? fix or defer?
Comment 6 Tomas Jelinek 2016-11-30 02:32:59 EST
defer.
Comment 7 Shahar Havivi 2017-03-16 06:29:50 EDT
Cannot reproduce,
Try with 2-5 VMs with and without disks.
Barak can you reproduce it?
Comment 8 Shahar Havivi 2017-04-03 06:43:49 EDT
If you can reproduce it with engine logs please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.