Bug 1298242 - [RFE] API compatibility - compatibility of clients
[RFE] API compatibility - compatibility of clients
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: FutureFeature
Depends On:
Blocks: 1292074 1296125 1313485
  Show dependency treegraph
 
Reported: 2016-01-13 10:16 EST by Petr Vobornik
Modified: 2016-11-04 01:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: ipa-4.4.0-1.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:48:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tkt_4739.log (2.19 KB, text/plain)
2016-09-19 01:04 EDT, Abhijeet Kasurde
no flags Details
tkt_5943.log (148 bytes, text/plain)
2016-09-19 01:11 EDT, Abhijeet Kasurde
no flags Details
tkt_6009.log (1.16 KB, text/plain)
2016-09-19 01:18 EDT, Abhijeet Kasurde
no flags Details
tkt_5995.log (2.43 KB, text/plain)
2016-09-19 01:25 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Petr Vobornik 2016-01-13 10:16:34 EST
Description of problem:
As an Administrator I want to be able to install IdM client and use it’s CLI to manage IdM server, where IdM Server server has lower version than the client (for example, RHEL-7.2 client and RHEL-7.0 server) so that I do not have to use old version of client packages to do the task

Steps to Reproduce:
1. run any 'ipa' command from client newer than an IPA server. E.g. user-find

Actual results:
IPA command will fail because of version mismatch.

Expected results:
IPA command will succeed.

Additional info:
Comment 3 Petr Vobornik 2016-01-15 11:13:31 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4739
Comment 4 Jan Cholasta 2016-05-25 10:06:07 EDT
master:
https://fedorahosted.org/freeipa/changeset/c37aba291f60f01a2aef5ebbff7f4dfb23d9bb67
https://fedorahosted.org/freeipa/changeset/861294c0d62891dc9977e7203cc07496e35ec939
https://fedorahosted.org/freeipa/changeset/e0275abe6f5192e68b7f57acf37b01aaa89003ea
https://fedorahosted.org/freeipa/changeset/2f6b333187e150369e9f761520aaebca0b45c011
https://fedorahosted.org/freeipa/changeset/13b010685b60404e89ec0392ee3d4157fbb0788b
https://fedorahosted.org/freeipa/changeset/278fa29906093ead4977ae68eb3bf37613329102
https://fedorahosted.org/freeipa/changeset/f8cf136c55aeb20785c08c1fa6abf33cc3fe6291
https://fedorahosted.org/freeipa/changeset/71f960457ed2e2fe53c4c8ea5c37b50180d89a6a
https://fedorahosted.org/freeipa/changeset/3eaafe42b52d3c76517946fa4c2c1c120065b9fa
https://fedorahosted.org/freeipa/changeset/213237c7fe053b43589de4bc64a871861da6db9a
https://fedorahosted.org/freeipa/changeset/ac2e9e84cf67b59488a07ffe932019ce3e23b41a
https://fedorahosted.org/freeipa/changeset/77e27de147729be36d19c89e21d5aa319412dc67
https://fedorahosted.org/freeipa/changeset/b08f7715180c83b3dd15fd7547bf854a36d93278
https://fedorahosted.org/freeipa/changeset/3f5091b55abed3a2d3f4b6b940fdb6bacabbf4fe
https://fedorahosted.org/freeipa/changeset/0d62968b6f853246d38b06e8378cb9cae7f9bbb4
https://fedorahosted.org/freeipa/changeset/bed546ee8220992084520737320a646dc47ec1e3
https://fedorahosted.org/freeipa/changeset/15a4c0d2767c0a37d55463d4bba60442a83539bb
https://fedorahosted.org/freeipa/changeset/88c0b66abc69ea5ab4a5beb72a1de2c5a74fd0c6
https://fedorahosted.org/freeipa/changeset/a30bc8a351b983725c082e603f311e17a6d0178e
https://fedorahosted.org/freeipa/changeset/60fa6ed4442279c2c42a72ee34c51b401e6a18d0
https://fedorahosted.org/freeipa/changeset/f28cd62285dd6336fa7919b700149b23567595da
https://fedorahosted.org/freeipa/changeset/1bcf08aab69821bea26c288cda02537a110372f8
https://fedorahosted.org/freeipa/changeset/b6af621432a4120f1e895315259537546dd99f4d
https://fedorahosted.org/freeipa/changeset/eb8be95043210cf3be0e07d3def1bd3439f9e540
https://fedorahosted.org/freeipa/changeset/be471699b637526ab613eabfe97ce2c4a55f0529
https://fedorahosted.org/freeipa/changeset/4a243536b3200caff80f9f8317892e3b38888edf
https://fedorahosted.org/freeipa/changeset/b09b92831f8b8cda26dcf01a04113ae6547b355c
https://fedorahosted.org/freeipa/changeset/4b119e21a2f93ca16c5edf3d1058552b44feeaf8
https://fedorahosted.org/freeipa/changeset/9e3c16e322ffc65e7d0799bcfbadec5df0ce1ad6
https://fedorahosted.org/freeipa/changeset/2b50fc617024f18a81e97f30f75ed1b9221c4055
Comment 6 Jan Cholasta 2016-06-03 02:54:50 EDT
master:
https://fedorahosted.org/freeipa/changeset/f90ecb061302ea15439b24c85e1d7b262ecff424
https://fedorahosted.org/freeipa/changeset/868a5cadbb4b662ed6b822108a8b0346c1d0cbf5
https://fedorahosted.org/freeipa/changeset/f57394f0ddddd1ab00d97d89c0e0dc407daa49a4
https://fedorahosted.org/freeipa/changeset/67826a8ba1ab19dc158bb4031df6cc89e1ef6250
https://fedorahosted.org/freeipa/changeset/7b25efa686c5da47d70dbbda03a99963aafd0715
https://fedorahosted.org/freeipa/changeset/af98aefd8094860c7bbe11ce706732e60665e053
https://fedorahosted.org/freeipa/changeset/54c73a170eee387f4f422a0ceb04be910829c55a
https://fedorahosted.org/freeipa/changeset/1d298ecc78e0e6a9529fcfc6709c1aaec3de5789
https://fedorahosted.org/freeipa/changeset/70b980d92f388a0c7bd1c4e9af1d57cb0cfa84b1
https://fedorahosted.org/freeipa/changeset/db9399161616d1db0889cb3237523f3abd301f22
https://fedorahosted.org/freeipa/changeset/a9c7a78bac276cd18fd8ed0a4253ca9c93e832a8
https://fedorahosted.org/freeipa/changeset/2922086c59724213ae48e02df310c6a1d85a4ecd
https://fedorahosted.org/freeipa/changeset/00d46a39b01bf8b6c9de8f5c3d3e5cea2468dcc3
https://fedorahosted.org/freeipa/changeset/a11182167cfcc6ad593111f3feaf6867a923fc48
https://fedorahosted.org/freeipa/changeset/3b6637777a872b4abcc1226be627bde90c8693b9
https://fedorahosted.org/freeipa/changeset/a6668af7897647d64726aa382309b33cf1f286b9
https://fedorahosted.org/freeipa/changeset/aaeeda99f197f2abdfdd7457eb33d22a242da4b5
https://fedorahosted.org/freeipa/changeset/138fcfcb087a8216e39a37b8bbfd80166ec6b5dd
https://fedorahosted.org/freeipa/changeset/7204601d8caf3da923c04c11024a5b36d321dde4
https://fedorahosted.org/freeipa/changeset/ac6e3625d5724ecd9774975b053ec62d2d0c4652
https://fedorahosted.org/freeipa/changeset/da5e75cbeea1095b545f3038e4569ac383315f07
https://fedorahosted.org/freeipa/changeset/374bb3d2bdf6b11f2094f7e5d4249707719a1880
https://fedorahosted.org/freeipa/changeset/73956165481add6b2637d3600de16e35dfc7978a
https://fedorahosted.org/freeipa/changeset/10618b6246e0e27636f0ab12932aaa660aea2e8a
https://fedorahosted.org/freeipa/changeset/f63064d33e88d4c9312f7624a965508fa0c66de3
https://fedorahosted.org/freeipa/changeset/dd9b82a35633353a430e573f6d1a86658d41b0b2
https://fedorahosted.org/freeipa/changeset/2e15702eb9d33d942f197ec9e1367d04a1f19a34
https://fedorahosted.org/freeipa/changeset/286e1ff6039431ea030480730ca0aa0fed5577a1
https://fedorahosted.org/freeipa/changeset/065a5f076f0e84ccb9498f762c959814bf277c7d
https://fedorahosted.org/freeipa/changeset/984ced60558950292b8894a26b13d9f85c54952c
Comment 7 Jan Cholasta 2016-06-03 03:01:42 EDT
Ignore the last comment, it contains wrong commit ids. These are the correct ones:

master:
https://fedorahosted.org/freeipa/changeset/748a4c31bf9018482b411578127eada176f47cec
https://fedorahosted.org/freeipa/changeset/9b0df69f75e70bcba60b0732dfca4b3dbc7eace4
https://fedorahosted.org/freeipa/changeset/f1ad3e67ae765ed6bf72fc861ffb47f1d6637c47
https://fedorahosted.org/freeipa/changeset/327d95296a5b28179469c20ec5f98dba3c333017
https://fedorahosted.org/freeipa/changeset/0a984afd8170b349b0745fb89168d363dfa28ffa
https://fedorahosted.org/freeipa/changeset/cd5ecdbaeef153523afdeff77f07945944118115
https://fedorahosted.org/freeipa/changeset/fe18adb25839bf191aa748f13e75bfccb10f4a57
https://fedorahosted.org/freeipa/changeset/ed4c2d9252a995d01dc098e5b761ded8cd9373d8
https://fedorahosted.org/freeipa/changeset/19cf6e950943725986bca5732e343c3a793f5b70
https://fedorahosted.org/freeipa/changeset/1391cd65ad87e70b9544c11cf8c9d22f54df2902
https://fedorahosted.org/freeipa/changeset/60d946241cc5a13050fd67873a2044df144d6743
https://fedorahosted.org/freeipa/changeset/b8988da0968e3b0bf27ac97a18b1ceae77e41cc3
https://fedorahosted.org/freeipa/changeset/6cfb9d73d9701767d8b76d7ff5bbc080a6be9386
https://fedorahosted.org/freeipa/changeset/4c7be74526bd89ed1b481f3a1ac4bb467ee0ea2c
https://fedorahosted.org/freeipa/changeset/98ede1b0e8c8473d6910fab2328dbc81d740945c
https://fedorahosted.org/freeipa/changeset/0e989e2a28fb8093528176574ffd2ae2ecac4c14
https://fedorahosted.org/freeipa/changeset/3cf5f83d92a2c315eb8a0dd2ed06cd1d61df5d36
https://fedorahosted.org/freeipa/changeset/f35beca68ceaab34ec1bed86be5ae49a0a931658
https://fedorahosted.org/freeipa/changeset/43dc424041e6766dbadd46f6f3982d85e69049cc
https://fedorahosted.org/freeipa/changeset/e056b8dea208ccde8e06b199809ce038ccd0531e
https://fedorahosted.org/freeipa/changeset/56c66f44a0e356504bf8a7edcc924777adc1b352
https://fedorahosted.org/freeipa/changeset/11de39651f1547464ce38f013bd4d2f88141569a
https://fedorahosted.org/freeipa/changeset/5a4a29be1c28e416174a9040d66c17d5288d3975
https://fedorahosted.org/freeipa/changeset/08ff248eeedd6dc4ebc5b118b7e4e81773594f51
https://fedorahosted.org/freeipa/changeset/875801d1d9406af6bcd4281962121f04b90287b7
https://fedorahosted.org/freeipa/changeset/2f7df393fd17b115112c39c714cc6c9b0b37460c
https://fedorahosted.org/freeipa/changeset/f5fd2b87506366f29ffca88b4a03e27143c79eae
https://fedorahosted.org/freeipa/changeset/ec841e5d7ab29d08de294b3fa863a631cd50e30a
https://fedorahosted.org/freeipa/changeset/6e44557b601f769d23ee74555a72e8b5cc62c0c9
https://fedorahosted.org/freeipa/changeset/8b7f2500ba16029faf02ae9318c0e1c51f60ffac
Comment 13 Jan Cholasta 2016-06-21 10:21:36 EDT
master:
* a5f48476adfd9971a1756bd5ad3cb7c9e2afef22 schema: return fingerprint as unicode text
Comment 14 Jan Cholasta 2016-06-27 01:38:45 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5943
Comment 15 Jan Cholasta 2016-06-27 01:38:55 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5968
Comment 16 Jan Cholasta 2016-06-27 01:39:00 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5995
Comment 20 Jan Cholasta 2016-06-29 04:15:45 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6009
Comment 21 Jan Cholasta 2016-06-29 04:18:43 EDT
Ticket 6009 fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/a77e21cbca05be422fe5826857cfba7e0ba6e71f
Comment 24 Jan Cholasta 2016-06-30 04:59:31 EDT
Ticket 6009 fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/8d5272e68775046db450d860c173a4d531a95ff2
Comment 25 Jan Cholasta 2016-06-30 05:01:27 EDT
Ticket 5995 fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/ce93b091d2ffbafedc721551f437631eed0e5a86
Comment 29 Jan Cholasta 2016-07-01 04:09:58 EDT
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/cea1f33606e85ac83a7bda66fbef318e47412531
Comment 31 Abhijeet Kasurde 2016-09-19 01:04 EDT
Created attachment 1202291 [details]
tkt_4739.log
Comment 32 Abhijeet Kasurde 2016-09-19 01:11 EDT
Created attachment 1202295 [details]
tkt_5943.log
Comment 33 Abhijeet Kasurde 2016-09-19 01:18 EDT
Created attachment 1202298 [details]
tkt_6009.log
Comment 34 Abhijeet Kasurde 2016-09-19 01:25 EDT
Created attachment 1202300 [details]
tkt_5995.log
Comment 35 Abhijeet Kasurde 2016-09-19 01:26:58 EDT
Verified using IPA version ::
ipa-server-4.4.0-12.el7.x86_64

Marking BZ as verified.
Comment 37 errata-xmlrpc 2016-11-04 01:48:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.