Bug 1298247 - Make dhcp_agent, l3_agent, ovs_agent and metadata_agent user-configurable.
Make dhcp_agent, l3_agent, ovs_agent and metadata_agent user-configurable.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Brad P. Crochet
Itzik Brown
:
Depends On: 1269252
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 10:18 EST by Brad P. Crochet
Modified: 2018-06-18 21:13 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.8-1.el7ost
Doc Type: Enhancement
Doc Text:
The Director now supports new parameters that control whether to disable or enable the following OpenStack Networking services: * dhcp_agent * l3_agent * ovs_agent * metadata_agent This enhancement allows the deployment of Neutron plug-ins that replace any of these services. To disable all of these services, use the following parameters in your environment file: NeutronEnableDHCPAgent: false NeutronEnableL3Agent: false NeutronEnableMetadataAgent: false NeutronEnableOVSAgent: false
Story Points: ---
Clone Of: 1269252
Environment:
Last Closed: 2016-04-07 17:45:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 230764 None None None 2016-01-13 10:18 EST
Red Hat Product Errata RHEA-2016:0604 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 director Enhancement Advisory 2016-04-07 21:03:56 EDT

  None (edit)
Comment 3 Itzik Brown 2016-03-13 05:45:51 EDT
Checked with openstack-tripleo-heat-templates-0.8.9-1.el7ost.noarch.
It's a good idea to change the name of the bug so that it's clear that we are talking about the controller.

Disabled the services using the following environment file
parameter_defaults:
  NeutronEnableDHCPAgent: false
  NeutronEnableL3Agent: false
  NeutronEnableMetadataAgent: false
  NeutronEnableOVSAgent: false

Checked that all the above services don't run and disabled

Enabled just the L3 agent and check that it's running and the other services are not.
Comment 4 Itzik Brown 2016-03-13 07:19:30 EDT
Is it correct that the variables are just for the controller?
Comment 6 errata-xmlrpc 2016-04-07 17:45:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.