Bug 1298262 - [RFE] Openstack provider shows resource groups as heat template stacks
[RFE] Openstack provider shows resource groups as heat template stacks
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: John Hardy
Dave Johnson
openstack:stack
: FutureFeature
Depends On:
Blocks: 1302810
  Show dependency treegraph
 
Reported: 2016-01-13 10:59 EST by Marco Berube
Modified: 2017-08-28 11:02 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1302810 (view as bug list)
Environment:
Last Closed: 2017-08-28 11:02:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bilwei: needinfo-


Attachments (Terms of Use)
Cloudforms UI screenshot showing all duplicated stacks (193.39 KB, image/png)
2016-01-13 10:59 EST, Marco Berube
no flags Details

  None (edit)
Description Marco Berube 2016-01-13 10:59:18 EST
Created attachment 1114441 [details]
Cloudforms UI screenshot showing all duplicated stacks

Description of problem:

I imported a HEAT template under "/services/catalogs/orchestration templates/heat template" and created some catalog items out of it.  My problem is that every time I provision this template, a new template is getting created for each resource group in my template and shows up in the list of templates available.

As an example, I imported a template named "lampstack", after provisioning this template, I see all the following heat templates:

-lamp01
-lamp-db-dj6ndfds2sa
-lamp01-web-2ndfdsjdh3
-lamp01-monitor-lkdjfslfsfs
-lampstack
etc...

* See attached file for more details.   

I see the same thing in "/clouds/stacks/".... all ressource groups provisioned in the past are showing up.


Version-Release number of selected component (if applicable):


How reproducible:

Easy to reproduce.

Steps to Reproduce:
1.  Import a heat template with resource groups
2.  Create a catalog item out of this template
3.  Provision this catalog item.

Actual results:

All resource groups are showing up as new stack heat templates in Cloudforms UI.  Where in openstack, I still only see one stack.


Expected results:

Heat stacks should not get duplicated every time I provision at stack with resource groups.


Additional info:
Comment 3 Greg Blomquist 2016-01-14 10:22:16 EST
Bill,

can you take a peek at this?  Not sure if this is just how OpenStack works...or if this is really something we should be handling differently.
Comment 6 Bill Wei 2016-01-18 16:00:05 EST
From OpenStack API, resource groups are listed as resources with type Resource Group under the parent stack. But the actual resource group object is returned as a nested stack of the parent. Our existing code correctly reflects these relationships.

MangeIQ's support for Azure provider already has the concept of resource group. In Azure each stack belongs to a resource group. It is a pity the concept is opposite with OpenStack, where resource groups belong to a stack. So we currently cannot unify two types of resource group in ManageIQ. We will continue to treat resource groups in OpenStack as nested stacks.

However ManageIQ should improve the presentation of stacks. Currently all stacks, root or nested, from all providers are shown in one flat table. A proper presentation should utilize the tree structure, starting from providers, then stacks at root level, and then nested stacks. Existing backend already supports the drill down operations.

Suggest to reassign to UI team for such enhancement.
Comment 7 Marco Berube 2016-01-25 07:33:21 EST
Not sure I understand what information is needed from me.   I still consider this a bug making Heat templates impossible to use with resource groups.
Comment 11 Loic Avenel 2016-02-22 07:15:25 EST
Issue discussed With Bill, a solution has been found and is under dev
Comment 14 Chris Pelland 2017-08-28 11:02:58 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.