Bug 1298267 - DEBUG:root:UI file does not exist: './src/gnome_abrt/oops.glade'
DEBUG:root:UI file does not exist: './src/gnome_abrt/oops.glade'
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-abrt (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jakub Filak
BaseOS QE - Apps
:
Depends On: 1287264
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 11:02 EST by Jiri Prajzner
Modified: 2016-11-30 19:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287264
Environment:
Last Closed: 2016-01-14 10:07:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Prajzner 2016-01-13 11:02:56 EST
+++ This bug was initially created as a clone of Bug #1287264 +++

Description of problem:
While runing gnome-abrt with verbose option, it reports missing oops.glade file

Version-Release number of selected component (if applicable):
gnome-abrt-1.2.0-5.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1. run gnome-abrt -v in terminal
2.
3.

Actual results:
gnome-abrt -v
/usr/bin/gnome-abrt:37: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
DEBUG:root:UI file does not exist: './src/gnome_abrt/oops.glade'

Expected results:
Clean execution without missing files

Additional info:
The file exists on my system: -rw-r--r--. 1 root root 44058 Aug 17 10:35 /usr/share/gnome-abrt/ui/oops.glade
Comment 2 Jakub Filak 2016-01-14 10:07:47 EST
Thank you for the report. gnome-abrt tries to load the file from two directories [1]. If none of those directories contain the file, gnome-abrt exits with an error. If the file is not found in a checked directory the debug message is printed out. In your case './src/gnome_abrt/oops.glade' does not exist because you are running a production version.

Please feel free to report any further bugs you find and re-open this bug report if needed.

https://github.com/abrt/gnome-abrt/blob/master/src/gnome_abrt/views.py#L295

Note You need to log in before you can comment on or make changes to this bug.