Bug 129827 - [PATCH] Some perl requirements aren't filtered out from the perl package if rebuilded with rpm 4.2.2
[PATCH] Some perl requirements aren't filtered out from the perl package if r...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: perl (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-12 19:42 EDT by Robert Scheck
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-5.8.0-88.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 13:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filter-depends.sh (216 bytes, text/plain)
2004-08-12 19:45 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2004-08-12 19:42:57 EDT
Description of problem:
Rebuilding RHEL3's perl package using the latest rpm package works
fine, but the installation of the successfull rebuilded perl 
packages doesn't work and dies with the following error:

--- snipp ---
Error: Failed dependencies:
        perl(OS2::Process) is needed by perl-5.8.0-88.4
        perl(Term::ReadKey) is needed by perl-5.8.0-88.4
        perl(Tie::RangeHash) is needed by perl-5.8.0-88.4
--- snapp ---

This error doesn't occur with the original rpm version delivered 
with RHEL3.

Version-Release number of selected component (if applicable):
rpm-4.2.2-0.14
perl-5.8.0-88.4

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. wget http://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/i386/SRPMS/perl-5.8.0-88.4.src.rpm
2. wget http://updates.redhat.com/enterprise/3ES/en/os/SRPMS/rpm-4.2.2-0.14.src.rpm
3. rpmbuild --rebuild rpm-4.2.2-0.14.src.rpm
4. rpm -Uvh /usr/src/redhat/RPMS/i386/rpm-*4.2.2*.i386.rpm
5. rpmbuild --rebuild perl-5.8.0-88.4.src.rpm
6. rpm -Uvh /usr/src/redhat/RPMS/i386/perl-*5.8.0-88.4*.i386.rpm
7. Get the error written above
  
Actual results:
rpm 4.2.2 seems to find new dependencies which rpm 4.2.1 didn't 
find, this breaks the installation of the fresh rebuilded perl rpms.

Expected results:
Fix either in the perl or in the rpm package...

Additional info:
I assigned this bug against rpm itself, because the original version
rpm delivered with RHEL3 hasn't that problem. Maybe that behaviour
of rpm 4.2.2 is correct, in this way perl should be changed using 
the attached patch.

FYI: cAos with CentOS 3 <http://www.centos.org/> already noticed 
this problem also, it's there described in their bugzilla: 
https://bugzilla.caosity.org/show_bug.cgi?id=519
They worked around it using the old original rpm...
Comment 1 Robert Scheck 2004-08-12 19:45:15 EDT
Created attachment 102685 [details]
filter-depends.sh

This filter-depends.sh from the perl package is modified and solves the issue
for me.
Comment 2 Robert Scheck 2004-08-17 19:05:39 EDT
Hm, after reviewing and some tests, I think, that I should file this 
report against perl not against rpm, the "new" rpm behaviour seems 
to be correct (in my eyes), changing.
Comment 3 Robert Scheck 2004-09-02 13:02:51 EDT
Thank you for solving my bug report with the RHEL3 errata in package 
perl-5.8.0-88.7.

Note You need to log in before you can comment on or make changes to this bug.