This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1298293 - v2v: import dialog - source VM list is not updated correctly.
v2v: import dialog - source VM list is not updated correctly.
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-rc
: 4.0.0
Assigned To: Sharon Gratch
Nisim Simsolo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 11:39 EST by Nisim Simsolo
Modified: 2016-07-05 04:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 04:03:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
tjelinek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
import dialog screenshot (147.52 KB, image/png)
2016-01-13 11:39 EST, Nisim Simsolo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57841 master MERGED webadmin: v2v-source vms list is cleaned in failure 2016-05-25 02:42 EDT

  None (edit)
Description Nisim Simsolo 2016-01-13 11:39:08 EST
Description of problem:
webadmin Import VM dialog > "virtual machines on source" list is not updated correctly it it was loaded before.
For example, when loading the list using valid VMware details and afterward loading the list again with invalid details, the VMs in the list from the first load action are still listed instead of being cleaned from list.

Version-Release number of selected component (if applicable):
rhevm-3.6.2-0.1.el6
libvirt-client-1.2.17-13.el7_2.2.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64
vdsm-4.17.15-0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Browse webadmin and navigate to virtual machines tab > import dialog.
2. Enter valid VMware parameters and click "load" button.
3. Enter incorrect VMware parameters and click "load" button.

Actual results:
"Virtual machines on source" list is still listed with VMs from the first load instead of being cleaned.

Expected results:
"Virtual machines on source" list shoud be updated in accordance to details entered and load action results. If it failed, the list should be cleared.

Additional info:
Screenshot attached.
Comment 1 Nisim Simsolo 2016-01-13 11:39 EST
Created attachment 1114465 [details]
import dialog screenshot
Comment 2 Sandro Bonazzola 2016-05-02 06:09:16 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Yaniv Lavi (Dary) 2016-05-23 09:24:57 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Yaniv Lavi (Dary) 2016-05-23 09:26:06 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 5 Sharon Gratch 2016-05-25 04:01:09 EDT
The bug was opened for VMware only, but the fix was done for all other external sources also (OVA, XEN, KVM). So now all sources behave the same and in case  loading failed then both vms lists are cleaned.
Comment 6 Nisim Simsolo 2016-06-09 04:57:31 EDT
Verification build: 
ovirt-engine-4.1.0-0.0.master.20160606111312.gitc7af584.el7

Verification scenario: 
1. Browse webadmin and navigate to virtual machines tab > import dialog.
2. Enter valid VMware parameters and click "load" button.
3. Enter incorrect VMware parameters and click "load" button, Verify "Virtual machines on source" pane is not listing any VM.
4. Enter different VMware environment details and click "load" button. Verify  
"Virtual machines on source" pane is listing new environment VMs correctly.
Comment 7 Sandro Bonazzola 2016-07-05 04:03:40 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.