Bug 1298308 - No logfile for launch-fusor-undercloud-installer
No logfile for launch-fusor-undercloud-installer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: TP2
: 1.0
Assigned To: Jason Montleon
Dave Johnson
: Triaged
Depends On:
Blocks: rhci-sprint-12
  Show dependency treegraph
 
Reported: 2016-01-13 12:52 EST by Thom Carlin
Modified: 2016-10-03 15:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:20:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2016-01-13 12:52:58 EST
Description of problem:

Expecting logfile for launch-fusor-undercloud-installer, none found

Version-Release number of selected component (if applicable):

TP2

How reproducible:

100%

Steps to Reproduce:
1. Install RHCIOOO ISO
2. Log in to start launch-fusor-undercloud-installer
3. Enter values and wait for installer to finish
4. Examine /var/log

Actual results:

No logfile found

Expected results:

Logfile found

Additional info:

To fix:
Change /usr/sbin/fusor-undercloud-installer line 3
from: fusor-undercloud-install 2>&1 /var/log/fusor-undercloud-install.log
to:   fusor-undercloud-install 2>&1 > /var/log/fusor-undercloud-install.log
                                    ^ Add greater than sign
Comment 1 Thom Carlin 2016-01-13 12:59:01 EST
Above fix is premature.  Please wait for real fix.
Comment 2 Thom Carlin 2016-01-13 14:02:48 EST
Alternatively, we could install tmux and use the copy buffer per https://unix.stackexchange.com/questions/26548/write-all-tmux-scrollback-to-a-file
Comment 4 Antonin Pagac 2016-01-25 08:27:46 EST
The log file is now present, but it seems it captures also the backspace key, so when user is removing the default entry, in the log it looks like:

<snip>
Enter the DNS nameserver to use for the Overcloud: 127.0.0.1^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K^H^[[K192.168.252.10
<snip>

Jason, please confirm this is the expected behavior.
Comment 5 Jason Montleon 2016-02-08 12:31:30 EST
tee will indeed capture all of this input. Don't know if it is desirable, but it is expected.
Comment 6 Antonin Pagac 2016-02-09 03:27:35 EST
Marking as verified.

RHCIOOO-7-RHEL-7-20160127.0-RHCIOOO-x86_64-dvd1.iso

Note You need to log in before you can comment on or make changes to this bug.