Bug 1298321 - unable to tag containers or pods
unable to tag containers or pods
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Ari Zellner
Avi Tal
container
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 13:47 EST by Felix Dewaleyne
Modified: 2016-04-27 03:26 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 04:24:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rananda: automate_bug-


Attachments (Terms of Use)

  None (edit)
Description Felix Dewaleyne 2016-01-13 13:47:09 EST
Description of problem:
unable to tag containers or pods

Version-Release number of selected component (if applicable):
5.5.0.13

How reproducible:
all the time

Steps to Reproduce:
1. go to containers > containers
2. select a couple containers
3. attempt to use policy > edit tags

Actual results:
error : method not implemented

Expected results:
able to alter tags on containers
Additional info:
the same error happens on containers (containers > pods).

This means that you cannot try to create a report that will filter containers by tag.
Comment 3 Federico Simoncelli 2016-01-14 04:59:45 EST
Ari I have the feeling we have seen/addressed something like this recently. Can you double-check if it's already fixed or if it's something new/different.

For containers there could be some new implications introduced by the fix for bug 1289694
Comment 4 Ari Zellner 2016-01-14 06:34:24 EST
Could not replicate on latest upstream or latest downstream(5.5.z)
for both pods and containers
Comment 9 Federico Simoncelli 2016-01-16 06:39:13 EST
Mooli, since you can reproduce the issue and Ari is going to be out for few days, can you reply the question above?

On 5.5.0.13 does it reproduces for pods? For containers? For both?

Container UI code changed quite a bit but Pods UI remained the same IIRC so why is it not reproducing on latest cfme-5.5.z?
Comment 10 Mooli Tayer 2016-01-18 08:39:05 EST
I could not reproduce the above all the way back to 5.5.0.0.
In all of those I could assign tags to pods. As for containers, since 5.5.1.0
the 'policy' selection box is disabled, but that does not seem to be the described problem.

Finally I retested on 5.5.0.13 with fresh db but still I was able to assign tags.

[1] 5.5.1.0 and 5.5.0.13 seem to tags of the same commit
the commits I tested:
5.5.z:             5b93864
5.5.1.0, 5.5.0.13: e9c3eea
5.5.0.0:           58436ca
Comment 11 Federico Simoncelli 2016-01-18 09:53:56 EST
Without logs or a reproducer we can't continue. Felix are you still experiencing the issue?
Comment 12 Felix Dewaleyne 2016-01-18 10:49:45 EST
I'm still waiting for logs. I haven't  been able to reproduce it on my environment yet (lacking an openshift)
Comment 13 Felix Dewaleyne 2016-01-19 06:19:29 EST
I've got data from the customer that would confirm that editing a single item works. However I am also remembering that in the recorded session that's attached to the case, I did try to select multiple tenants to attach a tag to them all in one go... it'd take me a while to be able to reproduce that due to having to deploy openshift in lab. if you're able to before, that is fine, otherwise I'll update the case again in a while.

Sorry for missing that point in the reproducer steps.
Comment 14 Avi Tal 2016-01-19 06:24:47 EST
Felix, I was automatically moving the ticket to myself but seems that you are still investigating it.
I this ticket requires specific setup to reproduce and you have all what it takes to do it then let me know and i'll move it back to you.
Comment 17 Federico Simoncelli 2016-02-02 04:24:30 EST
Felix, it seems that there are no additional information and it's not reproducible. I'll close this for the time being, feel free to reopen in case you have more information.

Thanks.
Comment 18 Felix Dewaleyne 2016-02-03 07:05:33 EST
I believe this may have been a temporary issue following a cookie expiring - the interface glitched and detected the usage of "back" when going quickly through tabs just before, and this has not been reproducible on the customer's system either. If I see it again I'll reopen this.

Note You need to log in before you can comment on or make changes to this bug.