Bug 1298348 - The command "hammer content-host list" takes over 4 minutes to execute
The command "hammer content-host list" takes over 4 minutes to execute
Status: CLOSED DUPLICATE of bug 1461194
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Performance (Show other bugs)
6.1.5
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 15:49 EST by Freddy Wissing
Modified: 2017-09-14 10:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-14 10:36:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Freddy Wissing 2016-01-13 15:49:25 EST
Description of problem:

Customer wants only a simple list of hosts.

The default action apparently calculates all installable errata counts for every host and takes way too long when I simply want a list of content hosts.  

Additionally, why try to calculate errata on ESX hypervisors?  there will never be any.  Also, can a filter be added to exclude hypervisors from the list?


Version-Release number of selected component (if applicable):

6.1.5

How reproducible:

Repeatably

Steps to Reproduce:
1.run # hammer content-host list and observe database and system activity


Actual results:

The command takes over four minutes to run.


Expected results:

Comes back with a simple list of content hosts.


Additional info:

Perhaps a flag could be added to allow just a simple list of hosts.
Comment 7 Bryan Kearney 2017-09-14 10:36:25 EDT
Marking this as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1461194 which will be delivered in 6.2.12. This will address the performance concerns.

*** This bug has been marked as a duplicate of bug 1461194 ***

Note You need to log in before you can comment on or make changes to this bug.