This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1298351 - RHEL 5 install of spacewalk-oscap package requires wrong dependency
RHEL 5 install of spacewalk-oscap package requires wrong dependency
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
2.4
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2016-01-13 15:55 EST by Matt Wilkinson
Modified: 2017-09-28 14:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 04:00:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Wilkinson 2016-01-13 15:55:04 EST
Description of problem:
According to https://www.open-scap.org/download/ instructions for downloading openscap on RHEL 5, the base package required is openscap-utils which also provides the oscap command. When attempting to install the spacewalk-oscap package on RHEL 5, the install fails because the package requires a dependency of openscap-scanner, which is not available for RHEL 5. The oscap command is provided by openscap-utils instead. 

The spacewalk-oscap package should be updated to require a dependency of openscap-utils instead. 

Version-Release number of selected component (if applicable):
Spacewalk 2.4, RHEL 5.11

How reproducible:
Always

Steps to Reproduce:
1. install openscap and openscap-utils
2. install spacewalk-oscap

Actual results:
error: Failed dependencies:
        openscap-scanner is needed by spacewalk-oscap-2.4.1-1.el5.noarch

Expected results:
successful installation of spacewalk-oscap

Additional info:

After forcing an install of spacewalk-oscap using rpm --nodeps, Spacewalk successfully works with RHEL 5 and only the openscap and openscap-utils packages installed.
Comment 1 Tomas Lestach 2016-01-22 09:22:29 EST
Switching to MODIFIED. This Bug was resolved by https://bugzilla.redhat.com/show_bug.cgi?id=1232596#c8
Comment 2 Tomáš Kašpárek 2016-06-16 04:00:46 EDT
Spacewalk 2.5 was released.
Comment 3 Eric Herget 2017-09-28 14:09:03 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.