Bug 129836 - exec of init failed!!!: 14 on CD boot
exec of init failed!!!: 14 on CD boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-13 00:14 EDT by Ellen Shull
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 17:03:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ellen Shull 2004-08-13 00:14:37 EDT
Description of problem: 
With an initrd created by recent versions of mkinitrd, boot from a 
"mkbootdisk --iso"-created boot CD fails on my system.  Relevant bit 
of boot messages (verbose version using nash-test for more info): 
 
Switching to new root 
exec of init (/sbin/init) failed!!!: 14 
Kernel panic: Attempted to kill init! 
 
Now unless I'm looking in the wrong header file, 14 is EFAULT, which 
from the execve man page means "filename points outside your 
accessible address space".  I wish that made sense to me... 
 
Version-Release number of selected component (if applicable): 
 
I've had this problem from current mkinitrd (4.0.5) back at least as 
far as 4.0.3.  4.0.0 worked fine (at least in this regard).  Not sure 
about 4.0.1 or 4.0.2; if you can point me to a place I can get those 
old versions, I'd be happy to retest with them. 
 
How reproducible: 
 
Using an affected version of mkinitrd, on my system, always.  
Unfortunately I have no idea which aspects of my system's 
configuration are causing the behavior.  I always boot off CD, having 
no boot partition configured, so I don't know if the CD booting is 
actually a factor. 
 
Additional info: 
 
Here's what things look like once I'm successfully booted: 
$ cat /etc/fstab 
LABEL=/                 /                       ext3    defaults        
1 1 
/dev/sda2               /media/temp             ext3    defaults        
1 2 
none                    /dev/pts                devpts  
gid=5,mode=620  0 0 
none                    /proc                   proc    defaults        
0 0 
none                    /dev/shm                tmpfs   defaults        
0 0 
/dev/sda1               swap                    swap    defaults        
0 0 
/dev/fd0                /mnt/floppy             auto    
noauto,owner,kudzu 0 0 
/dev/hdc                /mnt/cdrom              auto    user            
0 0 
none                    /var/lib/rpc_pipes      rpc_pipefs defaults 0 
0 
 
$ mount 
/dev/md0 on / type ext3 (rw) 
none on /proc type proc (rw) 
none on /dev/pts type devpts (rw,gid=5,mode=620) 
usbdevfs on /proc/bus/usb type usbdevfs (rw) 
/dev/sda2 on /media/temp type ext3 (rw) 
none on /dev/shm type tmpfs (rw) 
/dev/hdc on /mnt/cdrom type iso9660 (ro,noexec,nosuid,nodev) 
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw) 
none on /var/lib/rpc_pipes type rpc_pipefs (rw)
Comment 1 Jeremy Katz 2004-08-13 13:19:20 EDT
I've added some debugging printfs to nash's exec of init.  New nash
binary is at http://people.redhat.com/~katzj/nash-test-2.  If you
could grab that, copy it over /sbin/nash, and remake your initrd and
let me know what output you get, that would be helpful.
Comment 2 Ellen Shull 2004-08-13 17:43:48 EDT
Ok, with nash-test-2: 
 
initargs[1]: initrd=initrd.img 
initargs[2]: ro 
initargs[3]: psmouse.proto=bare 
initargs[4]: selinux=0 
initargs[5]: vga=ask 
initargs[6]: root=/dev/md0 
initargs[7]: BOOT_IMAGE=vmlinuz 
initargs[8]: single 
 
Then the same error 14. 
 
Parameter 8 came from me typing "linux single" at the isolinux boot 
prompt, and the rest appear to be consistent with the entry in my 
grub.conf: 
 
title Fedora Core (2.6.7-1.517) 
        root (hd0,0) 
        kernel /boot/vmlinuz-2.6.7-1.517 ro root=LABEL=/ 
psmouse.proto=bare selinux=0 vga=ask 
        initrd /boot/initrd-2.6.7-1.517.img 
 
The only idea I get out of that is that I have an awful lot of boot 
parameters; are we overrunning a buffer used to pass them to init or 
something? 
Comment 3 W. Michael Petullo 2004-08-14 13:39:13 EDT
I also have the "exec of init failed!!!: 14" problem.  I am trying to
boot using mkinitrd-4.0.5-1, patched to boot an encrypted filesystem
(see bug #124789).

Things worked fine with the 3.5 series of mkinitrd (no initramfs).

I can confirm that the encryped filesystem is properly mounted by
initrd.  I can also confirm that /sysroot/sbin/init exits at the time
of the switchroot call.

I modified nash.c to print debug messages similar to those above:

initargs[0]: /sbin/init
initargs[1]: root=/dev/hda5
initargs[2]: ro
initargs[3]: enforcing=1

I am running Rawhide on an iBook.
Comment 4 W. Michael Petullo 2004-08-14 14:10:48 EDT
This all seems to be fixed by the patch submitted for bug #129673.

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=102734&action=view
Comment 5 Ellen Shull 2004-08-14 18:07:44 EDT
I just tested the above patch, and it has fixed my problems too.  
Review it and roll it in! 
 
(Looking at what the patch fixes, all I can say is...  Dude?!) 
Comment 6 Jeremy Katz 2004-08-16 13:17:37 EDT
Should be happier with mkinitrd-4.0.6
Comment 7 Ellen Shull 2004-08-19 17:03:01 EDT
Yes, mkinitrd-4.0.6 works fine; thanks for your work.  Closing this 
bug now... 

Note You need to log in before you can comment on or make changes to this bug.