Bug 1298363 - docker: Backport device maper deferred device deletion fix in 1.9
docker: Backport device maper deferred device deletion fix in 1.9
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Walsh
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 17:26 EST by Vivek Goyal
Modified: 2016-03-31 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:23:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivek Goyal 2016-01-13 17:26:58 EST
Description of problem:

Device mapper graphdriver deferred device deletion feature has a bug which I 
recently fixed upstream and will show up in 1.10. As we will be enabling deferred device deletion by default in 1.9, I think it is important to backport that fix in 1.9.

https://github.com/docker/docker/pull/19241

Version-Release number of selected component (if applicable):

1.9.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2016-01-13 17:29:07 EST
Could you open a pull request on the rhel7-1.9 branch.
Comment 2 Vivek Goyal 2016-01-13 17:30:48 EST
Ok, will do
Comment 4 Daniel Walsh 2016-02-22 15:09:28 EST
Did this ever happen, or not fixed until docker-1.10
Comment 5 Daniel Walsh 2016-02-22 15:10:08 EST
Did this ever happen, or not fixed until docker-1.10
Comment 6 Vivek Goyal 2016-02-22 15:12:41 EST
I think it got pulled into rhel 1.9.

https://github.com/projectatomic/docker/pull/65
Comment 7 Daniel Walsh 2016-02-23 08:49:31 EST
Fixed in docker-1.9
Comment 9 Luwen Su 2016-03-18 04:36:09 EDT
I can only verify this by watching the log and the patch witin 
docker-1.9.1-23.el7.x86_64,

Starting docker daemon with
#docker daemon --storage-opt dm.use_deferred_removal=true --selinux-enabled --storage-opt dm.use_deferred_deletion=true -D

Trigger defer remove:
#docker run -ti --rm rhel7 /bin/bash
#docker run -ti -v /:/host rhel7 bash

exit the first container will trigger:
Deferred Deleted Device Count: 1

and after exit the second later, it will be to zero later
Comment 11 errata-xmlrpc 2016-03-31 19:23:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0536.html

Note You need to log in before you can comment on or make changes to this bug.