Bug 1298450 - overcloud deploy failed: Duplicate declaration: Nova_config[cinder/catalog_info]
overcloud deploy failed: Duplicate declaration: Nova_config[cinder/catalog_i...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Emilien Macchi
Ronnie Rasouli
: BuildBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 01:34 EST by Ronnie Rasouli
Modified: 2016-04-07 17:45 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-5.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:45:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 247694 None None None 2016-01-18 08:56 EST

  None (edit)
Description Ronnie Rasouli 2016-01-14 01:34:31 EST
Description of problem:
Deploying rhos8 with the following command detailed:in(http://file.tlv.redhat.com/~rrasouli/rhos8))

openstack overcloud deploy --templates ~/templates/my-overcloud   --control-scale 3 --compute-scale 1 --ntp-server clock.redhat.com   --libvirt-type qemu -e ~/templates/my-overcloud/environments/network-isolation.yaml -e templates/my-overcloud/environments/puppet-pacemaker.yaml  -e ~/templates/network-environment.yaml  -e ~/templates/firstboot-environment.yaml

Deployment failed

[stack@instack ~]$ heat resource-list overcloud  | grep -iv complete
+-------------------------------------------+-----------------------------------------------+---------------------------------------------------+-----------------+---------------------+
| resource_name                             | physical_resource_id                          | resource_type                                     | resource_status | updated_time        |
+-------------------------------------------+-----------------------------------------------+---------------------------------------------------+-----------------+---------------------+
| ComputeNodesPostDeployment                | 15cff0c6-77aa-4a49-b57c-dbd84db71ee3          | OS::TripleO::ComputePostDeployment                | CREATE_FAILED   | 2016-01-14T05:23:53 |
| ControllerNodesPostDeployment             | d055f2c7-4826-4168-9237-59c1d6eef75d          | OS::TripleO::ControllerPostDeployment             | CREATE_FAILED   | 2016-01-14T05:23:53 |
+-------------------------------------------+-----------------------------------------------+---------------------------------------------------+-----------------+---------------------+

From compute:

sudo journalctl -u os-collect-config


an 14 00:31:04 overcloud-novacompute-0.localdomain os-collect-config[8276]: [2016-01-14 00:31:04,654] (heat-config) [INFO] {"deploy_stdout": "", "deploy_stderr": "\u001b[1;31mError: Duplicate declaration: Nova_config[cinder/catalog_info] is already declared in file /etc/puppet/modules/nova/manifests/init.pp:684; cannot redeclare at /etc/puppet/modules/nova/manifests/config.pp:38 on node overcloud-novacompute-0.localdomain\u001b[0m\n\u001b[1;31mError: Duplicate declaration: Nova_config[cinder/catalog_info] is already declared in file /etc/puppet/modules/nova/manifests/init.pp:684; cannot redeclare at /etc/puppet/modules/nova/manifests/config.pp:38 on node overcloud-novacompute-0.localdomain\u001b[0m\n", "deploy_status_code": 1}
Jan 14 00:31:04 overcloud-novacompute-0.localdomain os-collect-config[8276]: [2016-01-14 00:31:04,654] (heat-config) [DEBUG] [2016-01-14 00:31:01,126] (heat-config) [DEBUG] Running FACTER_deploy_stack_id="overcloud-ComputeNodesPostDeployment-utqjaxzyidot-ComputePuppetDeployment-k7bfnak5f6iw/5d3f97dd-d6fb-42ed-a7b1-954fdf0d3ef7"  FACTER_deploy_signal_verb="POST"  FACTER_deploy_resource_name="0"  FACTER_fqdn="overcloud-novacompute-0.localdomain"  FACTER_deploy_signal_id="http://192.0.2.1:8000/v1/signal/arn%3Aopenstack%3Aheat%3A%3A308fa8a1ba774d62901dd95d9d396131%3Astacks%2Fovercloud-ComputeNodesPostDeployment-utqjaxzyidot-ComputePuppetDeployment-k7bfnak5f6iw%2F5d3f97dd-d6fb-42ed-a7b1-954fdf0d3ef7%2Fresources%2F0?Timestamp=2016-01-14T05%3A30%3A37Z&SignatureMethod=HmacSHA256&AWSAccessKeyId=5d9a8abdf7664ae2ac3abc414ff74fbf&SignatureVersion=2&Signature=dy0zRs1bujepX0POjdX5uljm%2B7hLavEH%2BucF9meOPRI%3D"  FACTER_heat_outputs_path="/var/run/heat-
Jan 14 00:31:04 overcloud-novacompute-0.localdomain os-collect-config[8276]: [2016-01-14 00:31:04,651] (heat-config) [INFO] Return code 1
Jan 14 00:31:04 overcloud-novacompute-0.localdomain os-collect-config[8276]: [2016-01-14 00:31:04,651] (heat-config) [INFO] Error: Duplicate declaration: Nova_config[cinder/catalog_info] is already declared in file /etc/puppet/modules/nova/manifests/init.pp:684; cannot redeclare at /etc/puppet/modules/nova/manifests/config.pp:38 on node overcloud-novacompute-0.localdomain
Jan 14 00:31:04 overcloud-novacompute-0.localdomain os-collect-config[8276]: Error: Duplicate declaration: Nova_config[cinder/catalog_info] is already declared in file /etc/puppet/modules/nova/manifests/init.pp:684; cannot redeclare at /etc/puppet/modules/nova/manifests/config.pp:38 on node overcloud-novacompute-0.localdomain
Jan 14 00:31:04 overcloud-novacompute-0.localdomain os-collect-config[8276]: [2016-01-14 00:31:04,651] (heat-config) [ERROR] Error running /var/lib/heat-config/heat-config-puppet/d94f9f4a-4af2-4227-a0ae-c59cc88f8551.pp. [1]



Version-Release number of selected component (if applicable):

openstack-heat-api-cloudwatch-5.0.0-1.el7ost.noarch
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-common-5.0.0-1.el7ost.noarch
heat-cfntools-1.2.8-2.el7.noarch
openstack-heat-templates-0-0.1.20151019.el7ost.noarch
openstack-heat-api-cfn-5.0.0-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.7-2.el7ost.noarch
openstack-heat-api-5.0.0-1.el7ost.noarch
openstack-heat-engine-5.0.0-1.el7ost.noarchopenstack-nova-compute-12.0.0-4.el7ost.noarch
openstack-nova-scheduler-12.0.0-4.el7ost.noarch
openstack-nova-cert-12.0.0-4.el7ost.noarch
python-nova-12.0.0-4.el7ost.noarch
openstack-nova-common-12.0.0-4.el7ost.noarch
python-novaclient-3.1.0-2.el7ost.noarch
openstack-nova-conductor-12.0.0-4.el7ost.noarch
openstack-nova-api-12.0.0-4.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch



How reproducible:
100%

Steps to Reproduce:
1. install undercloud on virt
2. patch as detailed https://bugzilla.redhat.com/show_bug.cgi?id=1298189
3. create your own images: overcloud image build --all
3. deploy with network isolation and controller follow the link above


Actual results:

Failure in deployment

Expected results:

deployment completed

Additional info:
Comment 2 Jason Guiditta 2016-01-14 10:00:01 EST
This is not an opm bug, it is because the downstream code for tht has in puppet/hieradata/compute.yaml:

nova::config::nova_config:
  cinder/catalog_info:
    value: 'volumev2:cinderv2:internalURL'


This config is already set in current versions of opm/nova/manifests/init.pp, so once tht gets updated to match upstream:
https://github.com/openstack/tripleo-heat-templates/blob/stable/liberty/puppet/hieradata/compute.yaml

This bug will be resolved.
Comment 5 Ronnie Rasouli 2016-03-09 15:57:10 EST
Was able to deploy without the suggested workaround on openstack-tripleo-heat-templates-0.8.9-1.el7ost.noarch
Comment 7 errata-xmlrpc 2016-04-07 17:45:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.