Bug 1298489 - Unable to update VIRTIO_SCSI flag via rest api
Unable to update VIRTIO_SCSI flag via rest api
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
3.6.2.5
x86_64 Unspecified
unspecified Severity high (vote)
: ovirt-3.6.2
: 3.6.2.6
Assigned To: Daniel Erez
Raz Tamir
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 04:20 EST by Tareq Alayan
Modified: 2016-02-18 06:14 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:14:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
amureini: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51839 master MERGED restapi: Fix update of virtio_scsi.enabled 2016-01-14 08:52 EST
oVirt gerrit 51934 ovirt-engine-3.6 MERGED restapi: Fix update of virtio_scsi.enabled 2016-01-18 04:26 EST
oVirt gerrit 52352 ovirt-engine-3.6.2 MERGED restapi: Fix update of virtio_scsi.enabled 2016-01-18 11:43 EST

  None (edit)
Description Tareq Alayan 2016-01-14 04:20:27 EST
Description of problem:
Unable to update VIRTIO_SCSI flag via rest api

Version-Release number of selected component (if applicable):
rhevm-3.6.2.5-0.1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a template with resource allocation:virtio_scsi is disabled (False)
2. update via rest  
PUT https://<engine-url>/api/templates/<template-id>
HEADER: Content-Type: application/xml
<template>
    <virtio_scsi enabled="true"/>
</template>

Actual results:
response body:
<virtio_scsi enabled="false"/>



Expected results:
<virtio_scsi enabled="true"/>


Additional info:
In short in rest api doesn't update the virtio_scci flag. 
Note that in the UI it is update it successfully.
Comment 1 Juan Hernández 2016-01-14 05:53:25 EST
This happens with templates and also with instance types. The proposed patch fixes the issue, and it has been verified it in the master and 3.6 branches.

Allon, can you assign the bug to someone in your team, so that she/he follows the bug to completion? Backporting to the 3.6 branch should be easy, just a cherry-pick, and I already verified it works.
Comment 2 Allon Mureinik 2016-01-14 06:57:23 EST
(In reply to Juan Hernández from comment #1)
> This happens with templates and also with instance types. The proposed patch
> fixes the issue, and it has been verified it in the master and 3.6 branches.
> 
> Allon, can you assign the bug to someone in your team, so that she/he
> follows the bug to completion? Backporting to the 3.6 branch should be easy,
> just a cherry-pick, and I already verified it works.
Thanks Juan!
Daniel - please take this one over.
Comment 3 Daniel Erez 2016-01-14 08:38:19 EST
(In reply to Allon Mureinik from comment #2)
> (In reply to Juan Hernández from comment #1)
> > This happens with templates and also with instance types. The proposed patch
> > fixes the issue, and it has been verified it in the master and 3.6 branches.
> > 
> > Allon, can you assign the bug to someone in your team, so that she/he
> > follows the bug to completion? Backporting to the 3.6 branch should be easy,
> > just a cherry-pick, and I already verified it works.
> Thanks Juan!
> Daniel - please take this one over.

Not sure how relevant for 3.6 since disks can't be added to an existing template any way. I.e. it could be needed only when creating a VM from a template, but then, can be changed from the new VM dialog.
Comment 4 Juan Hernández 2016-01-14 08:55:31 EST
Tareq, Nelly, how important is this for automation? Needs to be fixed in 3.6.z?
Comment 5 Allon Mureinik 2016-01-14 08:59:38 EST
(In reply to Juan Hernández from comment #4)
> Tareq, Nelly, how important is this for automation? Needs to be fixed in
> 3.6.z?

It's a trivial fix - let's just do it.
Comment 6 Tareq Alayan 2016-01-14 11:28:24 EST
Yes it will be very nice to have
Comment 7 Raz Tamir 2016-01-21 06:49:15 EST
Verified on rhevm-3.6.2.6-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.