This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1298530 - opensc-pkcs11.so crash firefox / chrome when a card is inserted
opensc-pkcs11.so crash firefox / chrome when a card is inserted
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: opensc (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Jelen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 06:24 EST by Juan Antonio Valiño García
Modified: 2016-10-04 01:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-04 01:55:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Antonio Valiño García 2016-01-14 06:24:05 EST
Description of problem:

That last version of opensc-pkcs11.so included in the opensc-0.15 package crash Firefox / Chrome when a card is inserted on the reader.

Version-Release number of selected component (if applicable):

The problem affects opensc-0.15.0-2.fc23 (stable repo) and also opensc-0.15.0-3.fc24 (rawhide repo)

How reproducible:

The problem is reproducible every time you insert a card after adding opensc-pkcs11.so library to the security devices on Firefox.

I've tried also with Chrome and a similar crash appears when I try to add the module to Chrome with a card inserted.

If I downgrade to previous version of opensc included in Fedora 22, all works perfectly.

Steps to Reproduce in FireFox:
1. Add the /usr/lib64/opensc-pkcs11.so library to the security devices on Firefox.
2. Insert a card in the card reader.

Actual results:

FireFox crashes.

Expected results:

Firefox must not crash.

Steps to Reproduce in Chrome:
1. Insert a card on the reader.
2. Add opensc-pkcs11 module to Chrome with the following command:

$ modutil -dbdir .pki/nssdb/ -add "opensc" -libfile /usr/lib64/opensc-pkcs11.so 

Actual results:

Chrome crashes.

Expected results:

Chrome must not crash.

Additional info:

If I downgrade the package to opensc-0.14.0-2.fc22.x86_64 (previous Fedora release) all seems to work. The command used to downgrade is this one:

# dnf downgrade --releasever=22 opensc*
Comment 1 Fedora Admin XMLRPC Client 2016-10-03 09:11:05 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Jakub Jelen 2016-10-03 09:18:18 EDT
Can you reproduce the same behavior with the package from Fedora 25 (upstream version 0.16.0)?

# dnf update --releasever=25 opensc*

Did you get any coredump with backtrace to share (preferably with debuginfo packages installed)? What type of card are you using?
Comment 3 Juan Antonio Valiño García 2016-10-04 01:55:19 EDT
I've tried the upstream version 0.16.0 you proposed and seems to work fine:

# rpm -qa | grep opensc
opensc-0.16.0-1.fc25.x86_64

Unfortunately I don't have any coredump, but seems that the problem has gone in the last version, so I think we can close the case.

Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.