Bug 1298534 - [SetupNetworks] attaching network with static boot protocol and IP cause the network to be un-synced
[SetupNetworks] attaching network with static boot protocol and IP cause the ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.2.5
x86_64 Linux
high Severity high (vote)
: ovirt-3.6.2
: 3.6.2.6
Assigned To: Alona Kaplan
Meni Yakove
:
Depends On:
Blocks: 1140850 1270807
  Show dependency treegraph
 
Reported: 2016-01-14 06:41 EST by Meni Yakove
Modified: 2016-02-18 06:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:03:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
danken: ovirt‑3.6.z?
myakove: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine log (3.15 MB, text/plain)
2016-01-14 06:41 EST, Meni Yakove
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52395 master MERGED engine: both null and empty gateway should be considered as no gateway 2016-01-19 03:28 EST
oVirt gerrit 52396 ovirt-engine-3.6 MERGED engine: both null and empty gateway should be considered as no gateway 2016-01-19 03:44 EST
oVirt gerrit 52397 ovirt-engine-3.6.2 MERGED engine: both null and empty gateway should be considered as no gateway 2016-01-19 03:45 EST

  None (edit)
Description Meni Yakove 2016-01-14 06:41:09 EST
Created attachment 1114757 [details]
engine log

Description of problem:
A network that attach to the host via SetupNetwork with static boot protocol and IP/Netmask ends up as a un-synced network.

Same results using netmask or prefix

Version-Release number of selected component (if applicable):
rhevm-3.6.2.5-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create network on DC and attach it to cluster
2. Attach the network to the host via SetupNetworks with boot protocol static, IP and netmask

Actual results:
The network is un-synced

Expected results:
The network is synced
Comment 1 Meni Yakove 2016-01-14 08:17:47 EST
The network is out of sync because the gateway is empty probably because of this fix https://gerrit.ovirt.org/#/c/51153/ (https://bugzilla.redhat.com/show_bug.cgi?id=1270688)
Comment 2 Red Hat Bugzilla Rules Engine 2016-01-17 07:24:53 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 3 Michael Burman 2016-01-21 04:39:47 EST
Verified on - 3.6.2.6-0.1.el6

Note You need to log in before you can comment on or make changes to this bug.