Bug 129858 - Kernel oops (NFS)
Kernel oops (NFS)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
: 129863 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-13 10:42 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 15:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
See if this patch helps.... (1.00 KB, patch)
2004-08-13 10:59 EDT, Steve Dickson
no flags Details | Diff

  None (edit)
Description Tim Waugh 2004-08-13 10:42:09 EDT
Description of problem:
Got this kernel oops on an NFS server running kernel-2.6.7-1.517.i686.

Version-Release number of selected component (if applicable):
2.6.7-1.517

How reproducible:
Not sure without rebooting.

Actual results:
CPU:    0
EIP:    0060:[<02134be8>]    Not tainted
EFLAGS: 00010246   (2.6.7-1.517)
EIP is at page_address+0x6/0x5f
eax: 00000000   ebx: 00000000   ecx: 0000000a   edx: 21fd8a00
esi: 0b6848c6   edi: 00000009   ebp: 19e34000   esp: 19e6cf1c
ds: 007b   es: 007b   ss: 0068
Process nfsd (pid: 3552, threadinfo=19e6c000 task=19e60600)
Stack: ffffd8fc 0b6848c6 00000009 19e34000 22a721df 00000001 00000001
21fd8a00
       19f83de0 22a2b65c 22a7000a 00000006 00000003 00000011 21fd8a00
21fd8a00
       22a720bc 22a86d58 22a86b18 22a684dd 19e75014 21fd8a64 21fd8a00
22a86d58
Call Trace:
 [<22a721df>] nfs3svc_decode_readargs+0x123/0x169 [nfsd]
 [<22a2b65c>] svc_udp_recvfrom+0x195/0x227 [sunrpc]
 [<22a7000a>] nfssvc_decode_symlinkargs+0x122/0x1ed [nfsd]
 [<22a720bc>] nfs3svc_decode_readargs+0x0/0x169 [nfsd]
 [<22a684dd>] nfsd_dispatch+0x6a/0x15d [nfsd]
 [<22a2ab3a>] svc_process+0x32b/0x569 [sunrpc]
 [<22a6833a>] nfsd+0x18e/0x2c7 [nfsd]
 [<22a681ac>] nfsd+0x0/0x2c7 [nfsd]
 [<021031d9>] kernel_thread_helper+0x5/0xb
Code: 8b 00 f6 c4 01 75 19 2b 1d 30 dd 37 02 c1 fb 05 c1 e3 0c 8d
 <1>Unable to handle kernel NULL pointer dereference at virtual
address 00000000 printing eip:
02134be8
*pde = 00000000
Oops: 0000 [#2]
Modules linked in: ovcamchip ov511(U) i2c_core v4l1_compat
snd_mixer_oss snd_via82xx snd_ac97_codec snd_pcm snd_timer
snd_page_alloc gameport snd_mpu401_uart snd_rawmidi snd_seq_device snd
soundcore raw1394 ieee1394 nfsd exportfs lockd sunrpc parport_pc lp
parport autofs4 tulip natsemi ipt_REJECT ipt_state iptable_filter
ipt_MASQUERADE iptable_nat ip_conntrack ip_tables floppy sg dm_mod
v4l2_common videodev sd_mod usb_storage scsi_mod usblp uhci_hcd button
battery asus_acpi ac md5 ipv6 ext3 jbd

Additional info:

/etc/exports:
/mnt/archive/rh 192.168.1.0/24(ro,sync)
Comment 1 Steve Dickson 2004-08-13 10:59:42 EDT
Created attachment 102701 [details]
See if this patch helps....
Comment 2 Steve Dickson 2004-08-13 11:47:04 EDT
*** Bug 129863 has been marked as a duplicate of this bug. ***
Comment 3 H.J. Lu 2004-08-13 16:45:03 EDT
The patch seems to work for me.
Comment 4 Tim Waugh 2004-08-16 06:54:47 EDT
Me too.

Note You need to log in before you can comment on or make changes to this bug.