Bug 1298586 - When you try to remove a pool that is not found no message/feedback is thrown to the user
When you try to remove a pool that is not found no message/feedback is thrown...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: William Poteat
Shwetha Kallesh
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 08:45 EST by Shwetha Kallesh
Modified: 2016-05-10 16:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:39:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2016-01-14 08:45:00 EST
Description of problem:
When you try to remove a pool that is not found no message/feedback is thrown to the user

Version-Release number of selected component (if applicable):
[root@dhcp35-189 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.10-1
subscription management rules: 5.19
subscription-manager: 1.16.7-1.el6
python-rhsm: 1.16.5-1.el6


How reproducible:


Steps to Reproduce:
when you provide invalid poolids along with invalid serial number , no message is thrown for invalid pool :
 
[root@dhcp35-189 ~]# subscription-manager remove --pool 8ac6a3f45215de5a015215dfb790073a --serial 5716740667283576794
Serial numbers unsuccessfully removed at the server:
   5716740667283576794
 
when you provide invalid poolids , no message is thrown for invalid pool :
 
[root@dhcp35-189 ~]# subscription-manager remove --pool 8ac6a3f45215de5a015215dfb790073a --pool 8ac6a3f45215de5a015215dfb3ea06d6

Actual results:
No message

Expected results:

should say something similar to " Pool '<poolid>' was not found."
Additional info:
Comment 2 Chris Snyder 2016-01-19 13:46:40 EST
In upstream master as of the following commit:

commit e418b77ce2a7389e310ac341a6beb46cb7eb3d0f
Author: William Poteat <wpoteat@redhat.com>
Date:   Mon Jan 18 13:22:15 2016 -0500

    1298586: Message needed for remove only invalid pool


This will be included in the next build (set to be completed today) before devel-freeze. As such I am moving this BZ to the modified state.
Comment 4 Shwetha Kallesh 2016-01-20 03:38:49 EST
I see the message for the invalid pool removal , hence moving bug to verified :

[root@hp-dl320egen8-01 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.10-1
subscription management rules: 5.19
subscription-manager: 1.16.8-1.el6
python-rhsm: 1.16.6-1.el6

[root@hp-dl320egen8-01 ~]# subscription-manager remove --pool 8ac6a3f45215de5a015215dfb790073a --pool 8ac6a3f45215de5a015215dfb3ea06d6

Pools unsuccessfully removed at the server:
   8ac6a3f45215de5a015215dfb790073a
   8ac6a3f45215de5a015215dfb3ea06d6


[root@hp-dl320egen8-01 ~]# subscription-manager remove --pool 8ac6a3f45215de5a015215dfb790073a --serial 5716740667283576794
Pools unsuccessfully removed at the server:
   8ac6a3f45215de5a015215dfb790073a
Serial numbers unsuccessfully removed at the server:
   5716740667283576794
Comment 6 errata-xmlrpc 2016-05-10 16:39:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.