Bug 1298588 - flat volumes have a serious bug that did not have before
flat volumes have a serious bug that did not have before
Status: CLOSED DUPLICATE of bug 1265267
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 08:47 EST by Sergio Monteiro Basto
Modified: 2016-01-18 16:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 16:54:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 355758 None None None 2016-01-14 09:37 EST

  None (edit)
Description Sergio Monteiro Basto 2016-01-14 08:47:49 EST
Description of problem:

Some people claim the same problem 
https://bugs.kde.org/show_bug.cgi?id=324975#c98

flat-volumes have a serious bug , I explained first here https://bugs.kde.org/show_bug.cgi?id=355758 but now I see that same happens in pavucontrol , in KDE, even without kmix running.  

Increasing the volume of one stream increases the volume of master channel , doesn't make sense I increasing volume sound in one stream audio and master audio is also increased ? . When I choose volume in one stream , master volume control shouldn't change to the same level of sound of the stream. 
Worst is I have a app saved which the stream was saved at maximum, I left application , I reduce master volume to very low level but not mute, I open the app and volume goes to maximum (same level of the stream of the app). Disabling flat-volumes , things back to normal i. e. master volume doesn't change when I change the level of a stream sound .

I don't want disable flat-volumes, I want someone fix flat-volumes in pulseaudio

Actual results:
I increasing volume sound in one stream and master is also increased

Expected results:
When I increasing volume sound in one stream and the master audio doesn't change 

Additional info:
Comment 1 Rex Dieter 2016-01-14 09:35:08 EST
As far as I understand, your description matches what flat volumes is designed to do.  Sounds like you simply don't like that.
Comment 2 Rex Dieter 2016-01-14 09:36:13 EST
(that said, apps that change volumes on their own *is* a problem, they shouldn't do that... it's not clear to me if that's the case here or not)
Comment 3 Sergio Monteiro Basto 2016-01-14 09:41:43 EST
When I increasing volume sound in one stream, the master channel shouldn't change and that was the behaviour in early of F21 IIRC
Comment 4 Rex Dieter 2016-01-14 09:55:02 EST
again, what you're describing is precisely what flat-volumes is designed to do, as far as I can tell.
Comment 5 Rex Dieter 2016-01-14 09:56:43 EST
from https://wiki.archlinux.org/index.php/PulseAudio:

... it scales the device-volume with the volume of the "loudest" application. For example, raising the VoIP call volume will raise the hardware volume and adjust the music-player volume so it stays where it was, without having to lower the volume of the music-player manually.
Comment 6 Rex Dieter 2016-01-14 09:59:46 EST
from the same section, looks like you're hitting a problematic app:

"Note: The default behavior upstream can sometimes be confusing and some applications, unaware of this feature, can set their volume to 100% at startup, potentially blowing your speakers or your ears..."
Comment 7 Sergio Monteiro Basto 2016-01-16 11:20:58 EST
I don't remember this behavior in F19 , F20 and until the middle of F21, 
I thought that flat volumes , should adjust the stream channel and not the master channel .
So I'm not sure about this, but I wonder if the defaults of pulseaudio have changed in these releases, finally if master channel could jump to 100% if a streamer have a bug, I agree that we should disable flat-volumes by default. 

Thanks.
Comment 8 Michael Catanzaro 2016-01-18 16:54:43 EST

*** This bug has been marked as a duplicate of bug 1265267 ***

Note You need to log in before you can comment on or make changes to this bug.