Bug 1298592 - Deploy of the second host failed if I have root password of the first host under answer file
Deploy of the second host failed if I have root password of the first host un...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.3.2.2
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: 2.0.0
Assigned To: Artyom
Artyom
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 08:56 EST by Artyom
Modified: 2016-07-05 04:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the root password of the first host is under answer file Consequence: answer file from first host wasn't fetched Fix: fixed the customization stage for fetching the answer file from first host even if the password is provided within an answer file Result: now it works.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 04:02:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51852 master MERGED packaging: setup: fix fetch of the answer file 2016-01-14 11:56 EST

  None (edit)
Description Artyom 2016-01-14 08:56:09 EST
Description of problem:
Deploy of the second host failed if I run deploy with the answer file and answer file has line "OVEHOSTED_FIRST_HOST/rootPassword=str:some_password"
 
Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.3.2.2-2.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy HE on the first host
2. Deploy the second host with the answer file:
[environment:default]
OVEHOSTED_FIRST_HOST/rootPassword=str:password
3.

Actual results:
Deployment failed with the traceback

2016-01-14 14:24:14 DEBUG otopi.context context._executeMethod:156 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 146, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/core/remote_answerfile.py", line 307, in _customization
    self._parse_answer_file()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/core/remote_answerfile.py", line 185, in _parse_answer_file
    self._config.read(self._tmp_ans)
  File "/usr/lib64/python2.7/ConfigParser.py", line 300, in read
    for filename in filenames:
TypeError: 'NoneType' object is not iterable


Expected results:
Deploy succeed

Additional info:
Comment 1 Artyom 2016-04-07 08:26:25 EDT
Verified on ovirt-hosted-engine-setup-2.0.0-0.0.master.20160325145108.gita9a3495.el7.centos.noarch
Comment 2 Sandro Bonazzola 2016-07-05 04:02:24 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.