Bug 1298611 - Retirement of vm doesn't work on amazon provider
Retirement of vm doesn't work on amazon provider
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: William Fitzgerald
Taras Lehinevych
ec2:vm:retirement
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 09:52 EST by Taras Lehinevych
Modified: 2016-08-02 21:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:29:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
amazon retire vm (119.89 KB, image/png)
2016-01-14 09:52 EST, Taras Lehinevych
no flags Details
automation.log (1.52 MB, text/plain)
2016-01-14 10:06 EST, Taras Lehinevych
no flags Details
evm.log (10.26 MB, text/plain)
2016-01-14 10:07 EST, Taras Lehinevych
no flags Details

  None (edit)
Description Taras Lehinevych 2016-01-14 09:52:05 EST
Created attachment 1114836 [details]
amazon retire vm

Description of problem:
When you retire vm the power state should be off/stooped, the status change to retired, however on amazon provider it wouldn't work, just writing that vm is retiring.
Please take a look at screenshot.
Also, I'll attach emv and automation log files.

Version-Release number of selected component (if applicable):
5.5.2.0

How reproducible:
Always

Steps to Reproduce:
1. Set up Amazon cloud provider
2. Open any virtual machine
3. Press Lifecycle -> Retire this VM
5. Wait and check the vm status and power state status.

Actual results:
The status of vm isn't retired I waited one hour but "Retirement state" 	is "Retiring"

Expected results:
The power state of vm should be off, the status of vm - retired and also cfme shouldn't allow vm to start/power on

Appliance info:
IP is 10.16.5.140
The vm name is i-a2532f7b
Comment 2 Taras Lehinevych 2016-01-14 10:06 EST
Created attachment 1114840 [details]
automation.log
Comment 3 Taras Lehinevych 2016-01-14 10:07 EST
Created attachment 1114842 [details]
evm.log
Comment 4 William Fitzgerald 2016-01-21 17:28:52 EST
I can't access your appliance.  Can I get access ?
Comment 5 Taras Lehinevych 2016-01-22 04:18:12 EST
William, 

Sorry, the appliance expired. 
Here is a new one: https://10.16.5.110
VM_name: i-a2532f7b
Comment 6 William Fitzgerald 2016-02-11 14:55:45 EST
Taras,

You are missing the generic check_pre_retirement method which Azure needs to retire a Vm when it is powered on.  The Vm is now showing a Retirement State of 'Error'
Once this is fixed, I will update this ticket and you. 

Thanks

Billy
Comment 7 William Fitzgerald 2016-02-11 15:20:54 EST
This issue has been resolved: https://github.com/ManageIQ/manageiq/pull/5779
Comment 8 Taras Lehinevych 2016-04-08 10:31:25 EDT
Verified in 5.6.0.0-beta1.20160322143549_f7ea680

Note that current default behavior of retirement is deleting vm.
Comment 10 errata-xmlrpc 2016-06-29 11:29:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.