Bug 1298612 - [RFE] RHEV-H should allow configuring multiple nics during setup
[RFE] RHEV-H should allow configuring multiple nics during setup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ovirt-4.0.0-beta
: ---
Assigned To: Fabian Deutsch
Wei Wang
: FutureFeature
: 1333450 1356352 (view as bug list)
Depends On: rhevh-next
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 09:52 EST by Marina
Modified: 2016-08-23 16:31 EDT (History)
21 users (show)

See Also:
Fixed In Version: rhev-hypervisor7-ng-3.6-20160429.0
Doc Type: Enhancement
Doc Text:
This update enables you to configure multiple NICs on a Red Hat Virtualization host to enable you to reach multiple networks at the same time.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 16:31:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ycui: testing_plan_complete?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2138791 None None None 2016-01-25 16:38 EST

  None (edit)
Description Marina 2016-01-14 09:52:08 EST
[RFE] RHEV-H TUI should allow configuring multiple nics.

Description of problem:
Right now RHEV-H TUI allows to configure only one network interface. Configuring any additional will reset the previous configuration.

There is a scenario, in which a second nic is required to be configured:
- Hosted Engine setup
- rhevm logical network is separate from the network for HE VM storage domain. And in order to proceed with HE setup, both networks should be configured.
(since there is no RHEVM yet to configure additional networks.)

Version-Release number of selected component (if applicable):
RHEVH 3.6.


How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H.
2. On Network configuration screen, configure one nic and save network.
3. On Network configuration screen, attempt to configure additional nick.

Actual results:
The system would delete the configuration of the first nick.

Expected results:
The system should let the second nick to be configured.
Comment 2 Fabian Deutsch 2016-01-14 09:56:14 EST
This will definetly be handled in RHEV-H Next, where cockpit can be used to configure multiple nics.

This is non trivial to achieve in RHEV-H vintage.
Comment 3 Marina 2016-01-14 11:35:04 EST
Sure. We just need to keep in mind that this scenario is possible as well. And handle it in the next implementation.
Comment 4 Yaniv Kaul 2016-03-03 10:42:09 EST
(In reply to Fabian Deutsch from comment #2)
> This will definetly be handled in RHEV-H Next, where cockpit can be used to
> configure multiple nics.

Can be moved to ON_QA?
Comment 5 Fabian Deutsch 2016-03-03 11:46:55 EST
Yes.

Steps to test:

1. Install Node Next
2. Enter cockpit
3. Configure multiple (at least 2) NICs with different networks
4. Run hosted-engine-setup (on the console) and use a storage device on one of the two networks

After 4: he-setup completes successfully.
Comment 9 Fabian Deutsch 2016-05-06 05:22:39 EDT
*** Bug 1333450 has been marked as a duplicate of this bug. ***
Comment 12 wanghui 2016-06-02 00:37:51 EDT
Test version:
rhev-hypervisor7-ng-4.0-20160527.0
cockpit-ovirt-dashboard-0.10.1-0.0.1.el7ev.noarch

Test steps:
1. Install rhev-hypervisor7-ng-4.0-20160527.0
2. Enter cockpit
3. Configure 2 NICs with different networks

Test result:
1. After step2, the 2 NICs can be up at the same time.

So this issue is fixed in rhev-hypervisor7-ng-4.0-20160527.0.
Comment 14 Marina 2016-07-15 10:37:05 EDT
*** Bug 1356352 has been marked as a duplicate of this bug. ***
Comment 15 Fabian Deutsch 2016-08-22 02:31:23 EDT
Removing a line from doctext due to bug 1367669, however, using ifcfg files, a user can still configure multiple interfaces on RHVH, thus keeping the RFE on this target milestone.
Comment 17 errata-xmlrpc 2016-08-23 16:31:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.