Bug 1298644 - Please provide python3-slugify
Please provide python3-slugify
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-slugify (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eduardo Mayorga
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 10:52 EST by Paul Belanger
Modified: 2016-01-17 20:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-17 20:32:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Belanger 2016-01-14 10:52:25 EST
python-slugify support python3, as such we should also ship python3 support. Please enable it for the RPM using the following[1]

Thanks,
PB

[1] https://fedoraproject.org/wiki/Packaging:Python
Comment 1 Paul Belanger 2016-01-14 11:13:05 EST
Ugh, this RPM is not https://pypi.python.org/pypi/python-slugify. Hmm, is there a specific reason you didn't use this version, which is more mature then the one you packaged?
Comment 2 William Moreno 2016-01-14 11:26:21 EST
python-frappe requires the older slugify to run.

https://github.com/frappe/frappe/blob/develop/requirements.txt

And for the momment frappe developers do not have plans to move to python3.

I will ask to the packaging mailing list about this to libs packaging.
Comment 3 Paul Belanger 2016-01-14 11:32:47 EST
Thanks for the fast reply, I also sent you a private email, which just extends some of the topic here. Just a heads up.

I will look into python-frappe and see how they are using it.
Comment 4 William Moreno 2016-01-14 12:34:46 EST
For the record:

https://lists.fedoraproject.org/archives/list/packaging%40lists.fedoraproject.org/thread/Z35EMXP5SCKJRR2IW2OKZ3QGWNZVNYPL/

https://github.com/frappe/frappe/pull/1521

I will wait some comment upstream but looks like I can retire python-slugify is frappe do not need any more.
Comment 5 Fedora Admin XMLRPC Client 2016-01-17 00:09:45 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Eduardo Mayorga 2016-01-17 11:07:28 EST
Note that the slugify in PyPI is not the same than python-slugify.

slugify: https://pypi.python.org/packages/source/s/slugify/slugify-0.0.1.tar.gz
python-slugify: https://github.com/un33k/python-slugify/archive/0.0.1.tar.gz

These are not the same source, so I cannot update the old slugify. It would make sense to retire this package in Rawhide as nothing requires it and make room for the new python-slugify.

Another solution would be to package the new PyPI's python-slugify as python-python-slugify (a legit name as per our Package Naming Guidelines), but that would only make things confusing and there is no need to keep the old slugify.
Comment 7 Zbigniew Jędrzejewski-Szmek 2016-01-17 11:58:19 EST
Are they more or less equivalent? If yes, I'd just switch to the other sources after reviewing them for license compatibility. After all, if this one is retired and a package with an identical name is added, for the user it's exactly the same as if the sources were switched. For the packagers it's less work.
Comment 8 Eduardo Mayorga 2016-01-17 20:32:56 EST
Building in Rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=12588750
Comment 9 Eduardo Mayorga 2016-01-17 20:48:31 EST
Sorry, this is the actual build: http://koji.fedoraproject.org/koji/taskinfo?taskID=12588760

Note You need to log in before you can comment on or make changes to this bug.