Bug 1298654 - clicking on 4B. Installation Progress, 2B. Engine, or 2C. Hypervisors a second time causes tab content to disappear
clicking on 4B. Installation Progress, 2B. Engine, or 2C. Hypervisors a secon...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
All All
unspecified Severity low
: ga
: 1.0
Assigned To: Fabian von Feilitzsch
Tasos Papaioannou
: Triaged
Depends On:
Blocks: rhci-sprint-16
  Show dependency treegraph
 
Reported: 2016-01-14 11:43 EST by Tasos Papaioannou
Modified: 2016-09-13 12:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:24:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tasos Papaioannou 2016-01-14 11:43:34 EST
Description of problem:

Within a deployment, click on 4B. Installation Progress to see the progress bars. Click on "4B. Installation Progress" again. The progress bars disappear. Similar behavior occurs on "2B. Engine" and "2C. Hypervisors": clicking on the link a second time causes the table to disappear, and you have to navigate to another tab then back for it to reappear.

Version-Release number of selected component (if applicable):

RHCI-6.0-RHEL-7-20160107.t.1

How reproducible:

100%

Steps to Reproduce:

See problem description above.

Actual results:

Clicking on tab name a second time causes the tab content to disappear.

Expected results:

Clicking on tab name a second time does not change the tab content.

Additional info:
Comment 1 Fabian von Feilitzsch 2016-05-06 16:52:42 EDT
This was caused by the link-to for these tabs not pointing to the full path of the tab's template. PR here https://github.com/fusor/fusor/pull/821
Comment 2 Tasos Papaioannou 2016-06-10 16:28:59 EDT
The problem is fixed for 4B. Installation Progress, 2B. Engine, and 2C. Hypervisors. If the deployment is for self-hosted RHEV, however, clicking on 2B. Engine/Hypervisor a second time shows the same issue. Can we get that one fixed too?
Comment 3 Fabian von Feilitzsch 2016-06-13 17:18:16 EDT
PR here, it looks like when self-hosted was merged in it reverted the change for the hypervisor tab. 

https://github.com/fusor/fusor/pull/944
Comment 4 jmagen@redhat.com 2016-06-14 03:59:25 EDT
PR merged.
Comment 5 John Matthews 2016-06-23 16:02:37 EDT
Addressed in ISO Set:
QCI-1.2-RHEL-7-20160623.t.0-QCI-x86_64-dvd1.iso
QCIOOO-8.0-RHEL-7-20160623.t.0-QCIOOO-x86_64-dvd1.iso
Comment 6 Tasos Papaioannou 2016-06-27 10:42:28 EDT
Verified on QCI-1.2-RHEL-7-20160623.t.0.
Comment 12 errata-xmlrpc 2016-09-13 12:24:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.