Bug 129866 - printing via a2ps wrong paper size and ugly result
printing via a2ps wrong paper size and ugly result
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: a2ps (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-13 11:54 EDT by Patrice Dumas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 11:34:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2004-08-13 11:54:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
When printing with a2ps:
[dumas@hermes these]$ a2ps -s2 ~/these.ps_pages 
[/home/dumas/these.ps_pages (ps, d�l�gu� � PsNup) : 7 pages sur 2
feuilles]
request id is kfet-147 (1 file(s))
[Total : 8 pages sur 2 feuilles] envoy� � l'imprimante par d�faut

The job sent requires letter paper, and when I force the printer to
print (on A4) the result is ugly, it seems the the resolution used for
printing is very bad, something like one half millimeter square for
each "pixel". 
(the messages above are, roughly: (ps, delegated to PsNup) : 7 pages
on two sheets.
And the second is [Total: 8 pages on 2 sheets]).

I configured the printer with:
[root@hermes root]# lpadmin -p kfet -m laserjet.ppd.gz -v
socket://kfet:9100 -o media=A4

lpr seems to print well.

Version-Release number of selected component (if applicable):
a2ps-4.13b-37

How reproducible:
Always

Steps to Reproduce:
1. print via a2ps
2.
3.
    

Actual Results:  a2ps tries to print on a letter paper, although the
printer was configured with A4. And the result is ugly.

Expected Results:  a beautifull printing.

Additional info:

The system was upgraded from a redhat 9 using yum. On the redhat 9
a2ps printed well. I didn't used printconf/system-config-printer to
configure the printers, only lpadmin. 

I have another problem with cups but I don't know if it is related or not:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=129864
Comment 1 Tim Waugh 2004-08-13 11:58:59 EDT
You need to use the -M option to set the page size.
Comment 2 Patrice Dumas 2004-08-13 12:11:08 EDT
Called with:

[dumas@hermes dumas]$ a2ps -s2 -MA4 these.ps_pages

Still the same.

I tried to print from openoffice, and it also wants to print on letter.
The quality seems fine, but there is only one page per sheet, thus it
isn't easy to know if the issue of ugly output is also present with
openoffice.
Comment 3 Patrice Dumas 2004-08-13 12:12:13 EDT
And also on redhat 9 the -M wasn't needed.
Comment 4 Tim Waugh 2004-08-19 10:11:24 EDT
I don't think a2ps is the problem here -- it's more likely that your
printer is configured incorrectly.

Please try using system-config-printer to configure it instead.
Comment 5 Patrice Dumas 2004-08-19 13:23:17 EDT
I figured out what was the problem.
I reconfigured my printer with 

lpadmin -p kfet -v socket://kfet:9100 -o media=A4

instead of

lpadmin -p kfet -m laserjet.ppd.gz -v socket://kfet:9100 -o media=A4

and now it works well. That's strange because the printer is an
HP laserjet 4200dtn
and also it used to work with that ppd file. Another strange thing is
that lpr printed well, but not a2ps or openoffice.

I also tried with system-config-printer. After I have run one or the
other lpadmin command, I just click on apply and it prints well.

Maybe this should be reassigned to cups? Otherwise it is notabug.

Note You need to log in before you can comment on or make changes to this bug.