Bug 1298662 - libzip conflict when upgrading from Fedora 22 to 23
libzip conflict when upgrading from Fedora 22 to 23
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libzip (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 12:05 EST by pcaviede
Modified: 2016-01-15 09:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 12:21:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pcaviede 2016-01-14 12:05:04 EST
Description of problem:
Upon upgrading onlie from Fedora server 22 to 23, the packages download correclly. After the transaction check, the system aborts the upgrade, giving the following error:

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib/libzip.so.4.0.0 from install of libzip-1.0.1-2.fc23.i686 conflicts with file from package libzip-last-1.0.1-1.fc22.remi.i686

Error Summary
-------------


Version-Release number of selected component (if applicable):
Upgrade from Fedora 22 to 23

How reproducible:


Steps to Reproduce:
1. dnf update
2. dnf install dnf-plugin-system-upgrade
3. dnf system-upgrade download --releasever=23  The latter also tried later with --best and --allowerasing options

Actual results:

See aforementioned error

Expected results:
Upgrade to F23

Additional info:
Comment 1 Rex Dieter 2016-01-14 12:06:48 EST
Where did this libzip-last-1.0.1-1.fc22.remi.i686 come from?
Comment 2 pcaviede 2016-01-14 12:12:13 EST
(In reply to Rex Dieter from comment #1)
> Where did this libzip-last-1.0.1-1.fc22.remi.i686 come from?

Not sure. I did a dnf update prior to the upgrade to F23, as suggested. I believe therepo is Les RPM de Remi
Comment 3 Remi Collet 2016-01-14 12:21:57 EST
Yes, 3rd party repo. Closing.
Comment 4 pcaviede 2016-01-14 12:27:04 EST
(In reply to Remi Collet from comment #3)
> Yes, 3rd party repo. Closing.

Any ideas, then?
Comment 5 Remi Collet 2016-01-14 12:28:42 EST
(In reply to pcaviede from comment #4)
> Any ideas, then?

Better to ask your provider ;)

Oh... wait... it's me.

Remove the packages installed from the 3rd party repo before the upgrade.
Comment 6 pcaviede 2016-01-14 12:34:02 EST
Tried to remove it via dnf remove. It says it would also remove all php files and squirrelmail:

 dnf remove libzip-last
Dependencies resolved.
=====================================================================================================================================================
 Package                                        Arch                     Version                                     Repository                 Size
=====================================================================================================================================================
Removing:
 libzip-last                                    i686                     1.0.1-1.fc22.remi                           @remi                      98 k
 php                                            i686                     5.6.17-1.fc22.remi                          @remi                     7.9 M
 php-bcmath                                     i686                     5.6.17-1.fc22.remi                          @remi                      96 k
 php-channel-phpseclib                          noarch                   1.3-2.fc21                                  @System                   886
 php-channel-phpunit                            noarch                   1.3-8.fc20                                  @fedora                   742
 php-cli                                        i686                     5.6.17-1.fc22.remi                          @remi                      12 M
 php-common                                     i686                     5.6.17-1.fc22.remi                          @remi                     7.8 M
 php-gd                                         i686                     5.6.17-1.fc22.remi                          @remi                     218 k
 php-gmp                                        i686                     5.6.17-1.fc22.remi                          @remi                     135 k
 php-mbstring                                   i686                     5.6.17-1.fc22.remi                          @remi                     2.4 M
 php-mcrypt                                     i686                     5.6.17-1.fc22.remi                          @remi                      90 k
 php-mysqlnd                                    i686                     5.6.17-1.fc22.remi                          @remi                     950 k
 php-pdo                                        i686                     5.6.17-1.fc22.remi                          @remi                     374 k
 php-pear                                       noarch                   1:1.10.1-1.fc22.remi                        @remi                     2.1 M
 php-pear-PHP-CodeSniffer                       noarch                   2.5.0-1.fc22.remi                           @remi                     3.2 M
 php-pecl-jsonc                                 i686                     1.3.9-1.fc22.remi.5.6                       @remi                     184 k
 php-pecl-zip                                   i686                     1.13.1-1.fc22.remi.5.6                      @remi                     166 k
 php-php-gettext                                noarch                   1.0.11-12.fc22.remi                         @remi                      57 k
 php-phpseclib                                  noarch                   2.0.0-4.fc22.remi                           @remi                     1.1 M
 php-phpseclib-crypt-aes                        noarch                   1.0.0-1.fc22.remi                           @System                   7.8 k
 php-phpseclib-crypt-base                       noarch                   1.0.0-1.fc22.remi                           @System                   100 k
 php-phpseclib-crypt-random                     noarch                   1.0.0-1.fc22.remi                           @System                    16 k
 php-phpseclib-crypt-rijndael                   noarch                   1.0.0-1.fc22.remi                           @System                    49 k
 php-phpunit-PHP-Timer                          noarch                   1.0.7-1.fc22.remi                           @System                   6.0 k
 php-process                                    i686                     5.6.17-1.fc22.remi                          @remi                     159 k
 php-recode                                     i686                     5.6.17-1.fc22.remi                          @remi                      25 k
 php-soap                                       i686                     5.6.17-1.fc22.remi                          @remi                     741 k
 php-symfony-class-loader                       noarch                   2.7.8-1.fc22.remi                           @remi                      60 k
 php-symfony-common                             noarch                   2.7.8-1.fc22.remi                           @remi                     384 k
 php-tcpdf                                      noarch                   6.2.12-1.fc22.remi                          @remi                      11 M
 php-tcpdf-dejavu-sans-fonts                    noarch                   6.2.12-1.fc22.remi                          @remi                     1.6 M
 php-tidy                                       i686                     5.6.17-1.fc22.remi                          @remi                     103 k
 php-udan11-sql-parser                          noarch                   3.0.8-1.fc22.remi                           @remi                     454 k
 php-xml                                        i686                     5.6.17-1.fc22.remi                          @remi                     814 k
 phpMyAdmin                                     noarch                   4.5.3.1-1.fc22.remi                         @remi                      22 M
 squirrelmail                                   noarch                   1.4.22-15.fc21                              @System                    20 M

Transaction Summary
=====================================================================================================================================================
Remove  36 Packages
Comment 7 Remi Collet 2016-01-14 12:37:10 EST
Definitively not the right place for this.
Not a Fedora bug.

> Remove the packages installed from the 3rd party repo before the upgrade.

and reinstall them after the update.
Comment 8 Remi Collet 2016-01-14 12:51:39 EST
Please file a bug on https://github.com/remicollet/remirepo/issues
Comment 9 Rex Dieter 2016-01-14 12:55:42 EST
remi, it is possible to add Obsoletes in place if you think it could help folks in this situation.
Comment 11 Rex Dieter 2016-01-14 12:59:13 EST
I meant putting an Obsoletes in the fedora libzip package (too)
Comment 12 Remi Collet 2016-01-14 13:01:08 EST
@Rex, ah ? 

But I don't think we can manage all existing 3rd repository in our Fedora spec.
So, IMHO, 3rd party repo issues have to be fixed there.

But thanks for the proposal.
Comment 13 pcaviede 2016-01-14 13:04:27 EST
(In reply to Remi Collet from comment #12)
> @Rex, ah ? 
> 
> But I don't think we can manage all existing 3rd repository in our Fedora
> spec.
> So, IMHO, 3rd party repo issues have to be fixed there.
> 
> But thanks for the proposal.

RIght. Meanwhile, is there any way to remove the lipzip-last package without compromising all the others?
Comment 14 pcaviede 2016-01-15 09:56:47 EST
(In reply to pcaviede from comment #13)
> (In reply to Remi Collet from comment #12)
> > @Rex, ah ? 
> > 
> > But I don't think we can manage all existing 3rd repository in our Fedora
> > spec.
> > So, IMHO, 3rd party repo issues have to be fixed there.
> > 
> > But thanks for the proposal.
> 
> RIght. Meanwhile, is there any way to remove the lipzip-last package without
> compromising all the others?

Syncig the repository did it! All good now! Thanks!

Note You need to log in before you can comment on or make changes to this bug.