Bug 1298670 - [RFE][ironic]: Adding support for vCenter in Ironic
[RFE][ironic]: Adding support for vCenter in Ironic
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
8.0 (Liberty)
x86_64 Linux
medium Severity low
: ga
: 10.0 (Newton)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
: FutureFeature, ZStream
Depends On:
Blocks: 1347518 1350510 1259436
  Show dependency treegraph
 
Reported: 2016-01-14 12:32 EST by Erwan Gallen
Modified: 2017-01-11 12:05 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-02 07:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erwan Gallen 2016-01-14 12:32:50 EST
Description of problem:

A customer wants to use some VMware ESXi VMs to install RHEL OSP controllers.
The deployment has to be managed by RHEL OSP-d.
The installation of RHEL OSP was tested with Ironic fake_pxe driver and worked well but we needed to reboot manually the ESXi instances during the deployment.

Expected results:

There is no Ironic driver to manage the power of ESXi threw vCenter API.
A patch has been developed to manage the power of nodes with a SSH driver to the ESXi hosts:
https://mojo.redhat.com/docs/DOC-1034793
For some users it's not possible to enable SSH on ESXi host because of security reasons, this SSH solution is not applicable for this customer.

We need to develop a vCenter driver for Ironic.

Additional info:
Most drivers in Ironic does use pyton-proliantutils (for ilo) python-dracclient (for drac), we can use perhaps this type of librairies for vCenter:
https://code.google.com/p/pysphere/wiki/GettingStarted
https://github.com/vmware/pyvmomi
Comment 3 Dmitry Tantsur 2016-01-21 08:58:45 EST
Does libvirt work with VMware ESXi? We have a proposal upstream to replace SSH driver with a libvirt driver to address SSH problems (e.g. better support Windows). Here is the spec: https://review.openstack.org/#/c/254421/
Comment 4 Dmitry Tantsur 2016-01-21 09:09:59 EST
Answering my own question: I've found http://libvirt.org/drvesx.html
"The libvirt VMware ESX driver can manage VMware ESX/ESXi 3.5/4.x/5.x and VMware GSX 2.0, also called VMware Server 2.0, and possibly later versions. Since 0.8.3 the driver can also connect to a VMware vCenter 2.5/4.x/5.x (VPX)."

Is your version included in the list? If so, we could probably try to land this libvirt driver.. Please take a look at the Ironic spec (link in the previous comment).
Comment 6 RHEL Product and Program Management 2016-08-02 07:38:35 EDT
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.