Bug 1298681 - nunc-stans -- upgrading liblfds
nunc-stans -- upgrading liblfds
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: wibrown@redhat.com
Viktor Ashirov
:
Depends On: 1298679
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 12:53 EST by Noriko Hosoi
Modified: 2017-08-01 17:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.6.1-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1298679
Environment:
Last Closed: 2017-08-01 17:10:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2086 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2017-08-01 14:37:38 EDT

  None (edit)
Description Noriko Hosoi 2016-01-14 12:53:37 EST
+++ This bug was initially created as a clone of Bug #1298679 +++

https://bugzilla.redhat.com/show_bug.cgi?id=1234277#c21
> Hello.
> 
> I am the author of liblfds.
> 
> On the 29th December 2015, release 7.0.0 was published.
> 
> Arch is now set always to 'native'.
> 
> The makefile appends to CFLAGS, which I think will still mean the appended
> values will be used rather than any existing values, so the 7.0.0 makefile
> does not solve the problem in this bug.
> 
> It's not apparent to me what the usual behaviour is supposed to be.  Should
> the makefile build its own CFLAGS and then append the existing CFLAGS?
> 
> Could you let me know what changes you'd like to see, and I'll get them in
> the next release (which will be quite soon, unlike 7.0.0, which took
> basically six years).
> 
> As an aside, perhaps of interest, 7.0.0 supports the Linux kernel.

> Oh - additionally - I will backport the makefile fixes to the earlier
> releases of liblfds.  I did not mean to imply you should use 7.0.0.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Noriko Hosoi 2016-01-14 13:01:03 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/48411
Comment 2 wibrown@redhat.com 2016-12-06 20:07:26 EST
This is resolved with the NS0.2.x update.
Comment 4 Viktor Ashirov 2017-04-06 07:13:59 EDT
Build tested:
389-ds-base-1.3.6.1-6.el7.x86_64

Source RPM bundles liblfds710.
Marking as VERIFIED.
Comment 5 errata-xmlrpc 2017-08-01 17:10:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2086

Note You need to log in before you can comment on or make changes to this bug.