Bug 1298729 - error message should be updated
error message should be updated
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 15:33 EST by Peter Ruan
Modified: 2016-01-19 19:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 19:28:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2016-01-14 15:33:17 EST
Description of problem:
Pod creation should fail when pod's node selector conflicts with project node selector.  It does, however, the error message used to be something like.

pods "east" is forbidden: pod node label selector conflicts with its project node label selector.  Where as currently pods just print '"east" already exists'  It looks like the older message is more appropriate for the situation.

Version-Release number of selected component (if applicable):
oc v1.1-734-gd198868
kubernetes v1.1.0-origin-1107-g4c8e6f4

How reproducible:
always.

Steps to Reproduce:
1. Create a project with node selector region=west
 oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/projects/node-selector.json
2. Create a pod with node selector region=east under project in step 1

oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/pods/selector-east.json -n jhou

Actual results:

"east" already exists
Expected results:
pods "east" is forbidden: pod node label selector conflicts with its project node label selector

Additional info:
Comment 1 Peter Ruan 2016-01-19 19:28:09 EST
it turned out it's a false error as I've done the wrong step.

Note You need to log in before you can comment on or make changes to this bug.