Bug 129873 - Rebuilding of gnupg always fails
Rebuilding of gnupg always fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnupg (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Mike McLean
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-13 13:10 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 20:20:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-08-13 13:10:40 EDT
Description of problem:
Rebuilding of gnupg will always fail, if the LANG environment 
variable isn't set to "C".

--- snipp ---
+ expect -f /usr/src/redhat/SOURCES/gnupg-shm-coprocessing.expect
gpg: DBG: mapped 4k shared memory at 0xb724b000, id=327680
gpg: WARNUNG: Unsichere Zugriffsrechte (homedir) "."
gpg: Schlüsselbund `./secring.gpg' erstellt
gpg: Schlüsselbund `./pubring.gpg' erstellt
gpg: Auf geht's - Botschaft eintippen ...
[ WAITING FOR INPUT / SAME AS "gnupg [enter]" ]
--- snapp --- 

Version-Release number of selected component (if applicable):
gnupg-1.2.5-0

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. export LANG=de_DE@euro
2. rpmbuild -ba gnupg.spec
3. Die with the error/problem described above, because German and
   English localized output aren't the same *hmpf*

Actual results:
Here's a diff from what is working for me:

--- snipp ---
--- gnupg.spec       2004-07-27 21:38:57.000000000 +0200
+++ gnupg.spec.rsc   2004-08-13 19:09:03.000000000 +0200
@@ -39,7 +39,7 @@

 make %{?_smp_mflags}
 make check
-expect -f $RPM_SOURCE_DIR/gnupg-shm-coprocessing.expect
+LANG=C expect -f %{SOURCE2}

 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -78,6 +78,9 @@
 %{_mandir}/man7/*

 %changelog
+* Fri Aug 13 2004 Robert Scheck <redhat@linuxnetz.de>
+- set LANG=C before running shm coprocessing build-time check
+
 * Tue Jul 27 2004 Nalin Dahyabhai <nalin@redhat.com> 1.2.5-1
 - update to 1.2.5

--- snapp ---

Expected results:
Use of the suggested changes ;-)
Comment 1 Nalin Dahyabhai 2004-11-01 20:20:28 EST
<whacks self on forehead>

Thanks!

Note You need to log in before you can comment on or make changes to this bug.