Bug 1298736 - [abrt] coreutils: set_program_name(): cat killed by SIGABRT
[abrt] coreutils: set_program_name(): cat killed by SIGABRT
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f21649dbc5694b13a490f417199...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 16:04 EST by Richard Geary
Modified: 2016-01-17 19:44 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 12:52:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.98 KB, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: cgroup (284 bytes, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: core_backtrace (1.23 KB, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: dso_list (222 bytes, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: maps (1.42 KB, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: mountinfo (5.14 KB, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: namespaces (85 bytes, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: open_fds (186 bytes, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: proc_pid_status (1010 bytes, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details
File: var_log_messages (289 bytes, text/plain)
2016-01-14 16:04 EST, Richard Geary
no flags Details

  None (edit)
Description Richard Geary 2016-01-14 16:04:13 EST
Description of problem:
Running JetBrains CLion, I ran a gtest application which succeeded

Version-Release number of selected component:
coreutils-8.24-4.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        
crash_function: set_program_name
environ:        
executable:     /usr/bin/cat
global_pid:     26515
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (1 frames)
 #2 set_program_name at lib/progname.c:56

Potential duplicate: bug 1108414
Comment 1 Richard Geary 2016-01-14 16:04:20 EST
Created attachment 1114950 [details]
File: backtrace
Comment 2 Richard Geary 2016-01-14 16:04:21 EST
Created attachment 1114951 [details]
File: cgroup
Comment 3 Richard Geary 2016-01-14 16:04:22 EST
Created attachment 1114952 [details]
File: core_backtrace
Comment 4 Richard Geary 2016-01-14 16:04:24 EST
Created attachment 1114953 [details]
File: dso_list
Comment 5 Richard Geary 2016-01-14 16:04:25 EST
Created attachment 1114954 [details]
File: limits
Comment 6 Richard Geary 2016-01-14 16:04:26 EST
Created attachment 1114955 [details]
File: maps
Comment 7 Richard Geary 2016-01-14 16:04:27 EST
Created attachment 1114956 [details]
File: mountinfo
Comment 8 Richard Geary 2016-01-14 16:04:28 EST
Created attachment 1114957 [details]
File: namespaces
Comment 9 Richard Geary 2016-01-14 16:04:29 EST
Created attachment 1114958 [details]
File: open_fds
Comment 10 Richard Geary 2016-01-14 16:04:31 EST
Created attachment 1114959 [details]
File: proc_pid_status
Comment 11 Richard Geary 2016-01-14 16:04:32 EST
Created attachment 1114960 [details]
File: var_log_messages
Comment 12 Ondrej Vasik 2016-01-15 12:52:21 EST
This is not a bug.

Snippet from the code (lib/progname.c):
if (argv0 == NULL)
    {
      /* It's a bug in the invoking program.  Help diagnosing it.  */
      fputs ("A NULL argv[0] was passed through an exec system call.\n",
             stderr);
      abort ();
    }


In other words, if you run exec which calls the program, but with argv[0] NULL, program aborts and - and this is expected behaviour chosen by upstream.
Comment 13 sedrubal 2016-01-17 19:44:26 EST
Another user experienced a similar problem:

I started ls with an empty argv...

char *args[] = { NULL };
execvp("ls", args);

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        
crash_function: set_program_name
environ:        
executable:     /usr/bin/ls
global_pid:     10997
kernel:         4.3.3-300.fc23.x86_64
package:        coreutils-8.24-5.fc23
reason:         ls killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Note You need to log in before you can comment on or make changes to this bug.