This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1298737 - Running 'rescan-scsi-bus -u' deletes /dev/null
Running 'rescan-scsi-bus -u' deletes /dev/null
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sg3_utils (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
David Jež
:
Depends On: 1245302
Blocks: 1203710 1313485 1289025 1295829
  Show dependency treegraph
 
Reported: 2016-01-14 16:10 EST by David Sommerseth
Modified: 2016-11-03 22:54 EDT (History)
6 users (show)

See Also:
Fixed In Version: sg3_utils-1.37-7.el7
Doc Type: Bug Fix
Doc Text:
When running the rescan-scsi-bus.sh script, due to incorrect syntax in redirecting output to the /dev/null device file while executing the /bin/rm utility, the redirection did not happen but /dev/null was instead interpreted as a file to be removed. As a consequence, running rescan-scsi-bus.sh with the "--update" option removed /dev/null during execution. This bug has been fixed, and /dev/null is no longer removed by rescan-scsi-bus.sh.
Story Points: ---
Clone Of: 1245302
Environment:
Last Closed: 2016-11-03 22:54:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 David Sommerseth 2016-04-15 18:19:48 EDT
Doc text is taken from bug #1245302 (RHEL6) resolving the same issue.
Comment 10 errata-xmlrpc 2016-11-03 22:54:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2296.html

Note You need to log in before you can comment on or make changes to this bug.