Bug 1298753 - keyboard layout switcher missing on the login screen
keyboard layout switcher missing on the login screen
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm (Show other bugs)
7.2
All Linux
high Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Desktop, Regression
Depends On:
Blocks: 1203710 1297830 1313485
  Show dependency treegraph
 
Reported: 2016-01-14 17:37 EST by Joe Wright
Modified: 2016-11-04 02:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: gdm-3.14.2-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:39:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (39.94 KB, image/png)
2016-01-14 17:37 EST, Joe Wright
no flags Details
gsettings-danish (105.76 KB, text/plain)
2016-01-18 11:14 EST, Joe Wright
no flags Details
gsettings-US (105.76 KB, text/plain)
2016-01-18 11:15 EST, Joe Wright
no flags Details

  None (edit)
Description Joe Wright 2016-01-14 17:37:57 EST
Created attachment 1114981 [details]
screenshot

Description of problem:
- keyboard layout switcher missing from login screen after updating
- unable to change keyboard layouts at login screen

Version-Release number of selected component (if applicable):
- current

How reproducible:


Steps to Reproduce:
1. Configure gnome or KDE for desired layout
2. configure keyboard switcher layouts
3. upgrade to 7.2 and reboot

Actual results:
- keyboard layout switcher missing
- GDM does not follow layout parameters for either KDE or Gnome

Expected results:
- able to switch keyboards as usual

Additional info:
see attached screenshot. There is a physical gap where the switcher should be.
Comment 4 Joe Wright 2016-01-18 09:22:54 EST
This issue does not exist in RHEL 7.2 server, only 7.2 workstation.
Comment 6 Joe Wright 2016-01-18 11:14 EST
Created attachment 1115876 [details]
gsettings-danish
Comment 7 Joe Wright 2016-01-18 11:15 EST
Created attachment 1115877 [details]
gsettings-US
Comment 9 Joe Wright 2016-01-18 11:18:32 EST
Attached gsettings from 7.2 server showing that there is no change between US and Danish keyboard settings, as well as sosreport from 7.2 server.
Comment 13 Joe Wright 2016-01-19 09:45:23 EST
- Upgraded from 7.1 -> 7.2
- They used the attached kickstart to configure gnome
- waiting on response from customer for 00-keyboard.conf and localectl outputs
Comment 19 Michael Boisvert 2016-09-01 10:49:16 EDT
I am able to configure multiple keyboard layouts for the login screen on a machine with KDE or GNOME.
Comment 21 errata-xmlrpc 2016-11-04 02:39:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2451.html

Note You need to log in before you can comment on or make changes to this bug.