Bug 1298787 - [RFE]openshift-ansible should support containerized ha-master installation
[RFE]openshift-ansible should support containerized ha-master installation
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Scott Dodson
Gan Huang
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 23:04 EST by Ma xiaoqiang
Modified: 2017-07-24 10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-12 14:47:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2016-01-14 23:04:11 EST
Description of problem:
openshift-ansible do not support containerized ha-master installation

Check the playbooks
1. No haproxy package on Atomic host, and the playbooks do not install the package
---
- name: Install haproxy
  action: "{{ ansible_pkg_mgr }} name=haproxy state=present"
  when: not openshift.common.is_containerized | bool

2. Can not find defined haproxy image in openshift_fact role
        master_image = 'openshift/origin'
        cli_image = master_image
        node_image = 'openshift/node'
        ovs_image = 'openshift/openvswitch'
        etcd_image = 'registry.access.redhat.com/rhel7/etcd'


Version-Release number of selected component (if applicable):
openshift-ansible master
commit ID: 2a12b6a99db4e8f39da27770e397dfafe27c9547


How reproducible:
always

Steps to Reproduce:
1. 
2.
3.

Actual results:
Can not install containerized ha-master env

Expected results:
playbooks support containerized ha-master 

Additional info:
Comment 1 Ma xiaoqiang 2016-01-15 04:39:05 EST
Install ha-master env. QE met the following error:

TASK: [haproxy | Configure haproxy] *******************************************
<--snip--> 
msg: Destination directory /etc/haproxy does not exist

FATAL: all hosts have already failed -- aborting
Comment 2 Brenton Leanhardt 2016-02-02 08:32:13 EST
This is being tracked here:
https://trello.com/c/ggjBrhgO/169-support-containerized-haproxy-for-ha-environments-using-lb-hosts
Comment 5 Scott Dodson 2017-01-22 15:21:11 EST
Community contribution which deploys the load balancer using the existing haproxy image https://github.com/openshift/openshift-ansible/pull/3106
Comment 8 Scott Dodson 2017-03-27 20:18:05 EDT
openshift-ansible-3.5.3-1 and newer should allow for containerized=true for lb hosts it makes use of the existing router image for haproxy.
Comment 9 Gan Huang 2017-03-28 05:08:19 EDT
Verified with openshift-ansible-3.5.45-1.git.0.eb0859b.el7.noarch

Step:

   1) Trigger installation with containerized Haproxy host

#cat inventory_hosts

<--snip-->

openshift_master_console_port=443
openshift_master_api_port=443

[lb]
openshift-xxx.com  containerized=true


Result:
   1) Installation successfully
   2) Docker was installed and Haproxy container run well on Haproxy host 
   3) Succeed to login Web console via haproxy hostname
   4) S2I build succeed
Comment 11 errata-xmlrpc 2017-04-12 14:47:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0903

Note You need to log in before you can comment on or make changes to this bug.