Bug 1298801 - dnf inline help not coherent across commands
dnf inline help not coherent across commands
Status: CLOSED DUPLICATE of bug 1158548
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 01:19 EST by Francois Rigault
Modified: 2016-01-19 09:46 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 09:46:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francois Rigault 2016-01-15 01:19:23 EST
Description of problem:

got me while wanting to disable a repo

    dnf config-manager
    (no answer)
    dnf config-manager --help
         --enablerepo [repo]
         --disablerepo [repo]
    (no detail on those two options, assume they do what I want)

the --help option, even displayed *after* the command name, will always show the general options. I found after that this the correct way to get help on a command:

    dnf help install

Also for config-manager this help is most unhelpful. In fact one would have to type

    dnf config-manager --help-cmd

to get the relevant options from config-manager

Currently on Fedora23 x86_64


Steps to Reproduce:
1. dnf config-manager --help is not helpful
2. dnf help config-manager is not helpful
3. dnf config-manager --help-cmd is never mentioned in dnf help page


Expected results:
--help option last line should be "Run dnf help command to get help on a command", at least if a command was specified

dnf help config-manager should give something meaningful


Additional info:
would it make sense to link to readthedocs.org in dnf output?
Comment 1 Honza Silhan 2016-01-19 09:46:36 EST

*** This bug has been marked as a duplicate of bug 1158548 ***

Note You need to log in before you can comment on or make changes to this bug.